Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Windows Vista Windows Vista
Search Search
Search for:
Tech Support Guy > > >

Vista partition broken by linux installation


(!)

onda_trollet's Avatar
onda_trollet onda_trollet is offline
Computer Specs
Junior Member with 2 posts.
THREAD STARTER
 
Join Date: Jul 2008
24-Jul-2008, 12:56 AM #1
Vista partition broken by linux installation
Short story: I installed Debian yesterday, latest version on my laptop. I had previously tried Slackware 12.1 which worked perfectly, but I never got internet to work. I have installed same Debian 2 months ago without any problems. I also have Vista (premium?) factory installed on the same hardrive as dualboot.

So... Debian yesterday. Grub bootloader. I always use lilo for slack though. I can see vista in the menu options. choose it... computer thinks and ponders a while and i see the normal "microsoft... something..." before i can log on to vista. but i cant log on. instead i get some acer rescue menu. it cant find the reason for me not being able to start vista. and there is no rescue point available according to it.

so... i try to install slack, hoping lilo will fix it hehe. i am not good with linux, you know. anyway... lilo works and everything... but i still cant log on to vista.

after trying to mount my win partition through linux to see if all is wasted or if the files are still there... it says it cant be mounted, check syslog. i am not good with reading syslog, but i see this:

invalid boot secot checksum

so fdisk -l in linux showed this:
fdisk -l:
Device Boot Start End Blocks Id System
/dev/sda1 * 1 1275 10240000 27 Unknown
/dev/sda2 1275 8570 58597087+ 83 Linux
/dev/sda3 8570 8813 1951897+ 5 Extended
/dev/sda5 8570 8813 1951866 82 Linux swap

My vista partition is "unknown".

i tinker some more in linux and manage to mount sda1 and ls it. I find files, but not "my files". they seem to be some sort of default files for that partition. I use the dos prompt in the acer rescue menu and find the same files.

looks like a big problem! is there anyway for me to fix this so i can log on to vista again? really depressed because i have a lot of important stuff on my win partition (and about 50 hours playtime on oblivion ). i can live with having to reinstall the whole computer and loose oblivion save, as long as i can save my photos and all those things.

thankful for help...
JohnUSAF's Avatar
JohnUSAF JohnUSAF is offline
Member with 61 posts.
 
Join Date: Sep 2005
Experience: Tech Support
24-Jul-2008, 08:59 AM #2
I would try to mount your windows partition using windows recovery console. Do you still have access to your Vista disk? If so I would boot using that and use recovery console to fix the MBR. I had this problem once when I deleted a linux partition on a dual boot XP/Fedora laptop. All I did was do recovery console and for the life of me I cannot remember the command but it worked. It's something like fixboot or fixmbr.
Mumbodog's Avatar
Member with 7,891 posts.
 
Join Date: Oct 2007
Experience: Advanced
24-Jul-2008, 11:36 AM #3
You can also try the Vista dvd to do a "startup repair"


http://www.bleepingcomputer.com/tuto...torial148.html
TechB's Avatar
TechB TechB is offline TechB has a Profile Picture
Senior Member with 446 posts.
 
Join Date: Jul 2006
Location: Squamish, BC, Canada
Experience: Advanced
24-Jul-2008, 10:54 PM #4
It sounds like grub is pointing to your Acer recovery partition instead of the Vista partition. Look in /boot/grub/menu.lst (in Linux) and see what partition grub is chaining to to load Vista. It's very likely that editing this file to point to the correct partition will allow you to boot to Vista.
onda_trollet's Avatar
onda_trollet onda_trollet is offline
Computer Specs
Junior Member with 2 posts.
THREAD STARTER
 
Join Date: Jul 2008
25-Jul-2008, 02:49 PM #5
startup repair does not work. and vista was preinstallad when i got it, no dvd. i need to do alt+f12 at boot to do a clean slate install of vista. i will try those commands though and see if they do any good. i am beginning to think though that i accidently erased my vista partition and thats the reason why it wont boot. the 10gb unknown partition probably is the recovery partition for reinstalling vista. i think so because the emergency repair to install vista again is on a hidden partition according to the manual.

thanks for the help though!
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑

Content Relevant URLs by vBSEO 3.3.2