Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Windows XP Windows XP
Search Search
Search for:
Tech Support Guy > > >

[SOLVED] "The specified service does not exist as an installed service."


(!)

deebeeeff's Avatar
deebeeeff deebeeeff is offline
Junior Member with 28 posts.
THREAD STARTER
 
Join Date: Jan 2004
29-Jan-2004, 12:34 PM #1
"The specified service does not exist as an installed service."
Please read the following carefully before replying. Thank you.
1) I have seen this problem posted on another forum in the past, but the thread never led to a solution.
2) This problem has occurred with both a EIDE hard drive and a USB camera. I have also seen reports of it happening with other drives.
(NOTE: the items I am referring to use native WIN XP drivers; I have posted this problem on other forums and the first responder always tells me to go to the manufactrer's site to download the latest drivers.)
3) The problem: every time I reboot, the Hardware installation wizard reports the following: "The specified service does not exist as an installed service."
4) Once this dialog box is closed, the yellow warning diamond appears nect to the device in hardware manager, and the driver "disk.sys" is NOT installed, although "partmgr.sys" is.
5) In all cases that I have and that I have seen reported, the DEVICE or DRIVE WORKS. I have found no operational problems with the drives. I have formatted, partitioned, put 20GB data on it, defragged it, etc. with no problems. I just hate the fact that eveyr time it boots up the system tries and fails to install it.
6) In investigating the setupapi.log file I find that it s trying to install a service with a garbage name.
7) In the HKLM,CurrentCtrlSet,etc entry for this drive, several lines are missing.
8) Please see the very long section attached which shows the following (not neccessarily in this order):
a) A successful installation log of my Maxtor drive, done back in October on my new machine
b) the failed install log of the WDC drive done the other day.
c) The registry entries for both items.
9) Mysystem: CompUSA computer built by Wintec; Intel D865GBF mobo, P4 2.8GHZ, 512 MB, Maxtor 160GB EIDE HD (installed at time comp was built - see succesful install log attached), WDC 160GB EIDE HD (works fine but never gets completely installed)
10) I use WINXP Home on a computer 4 months old. Every patch, upgrade and bios upgrade have been done. All available WINXP updates are done.

Again, please read things cerfully before you respond. I only emphasize this because I have, on other forums, received pages and pages of answers from people that obviously didn't read everything. THIS is NOT a USB problem. I have seen this same problem happen for others with any drive that uses "disk.sys"

Thanks in advance,
Dave
Attached Files
File Type: txt the whole wdc problem.txt (7.6 KB, 2428 views)
JayTheHun's Avatar
JayTheHun JayTheHun is offline
Member with 383 posts.
 
Join Date: Jun 2002
Location: WA State
29-Jan-2004, 02:22 PM #2
Sure sounds "system drivers-ish," to me. Do you know which company made the motherboard? I would look to install their own system drivers (particularly the IDE controller drivers) and especially updated drivers from the manufacturer's website, given that you're using Windows XP.
PC_Wiz's Avatar
Computer Specs
Senior Member with 1,245 posts.
 
Join Date: Nov 2003
Location: WA
29-Jan-2004, 03:11 PM #3
try this:

1. Open the Registry Editor. (Click Start and Run regedit.exe)

2. Go to the key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BBBFC1
-08002BE10318}

3. Right click the above key, choose Export and save the file as backup.reg.

4. Delete the LowerFilters value in the right panel. (NOTE: Under the key, there
are also some sub keys such as 0000, 0001. Please double click them and delete the
LowerFilters value.)

5. Restart the computer.

If this still does not work, please perform a Clean Boot to narrow down the problem.

1. Click Start, and click Run msconfig. The System Configuration Utility appears.

2. In the General tab, click Selective Startup.

3. Uncheck the processing options that are listed below Selective Startup except "Load System Services."

4. Click Apply, and then click Close.

5. Restart the computer and test if the issue persists.
deebeeeff's Avatar
deebeeeff deebeeeff is offline
Junior Member with 28 posts.
THREAD STARTER
 
Join Date: Jan 2004
29-Jan-2004, 09:00 PM #4
It worked, but what did it do?
PC_WIZ,
Thanks for your answer. It worked. Setupapi.log has exactly the expected data and the registry entry for the drive is just what it should be. I will try the USB camera next and hopefully have similar results.
However, 0000 and 0001 did not have Lower Filters. Is that a bad thing?
What are the Lower Filters?
Did the solution cause any other problems that I should be aware of?
Thanks again very much,
Dave
PC_Wiz's Avatar
Computer Specs
Senior Member with 1,245 posts.
 
Join Date: Nov 2003
Location: WA
03-Feb-2004, 06:36 PM #5
There area 3rd parties products that entries under the UpperFilters or LowerFilters value in the registry, either by adding its own filter drivers or by removing the registry keys values.

Dont worry about 0000 and 0001 not having Lower Filters.

Make sure to always backup the registry prior to any changes.
kunaladesai's Avatar
kunaladesai kunaladesai is offline
Junior Member with 1 posts.
 
Join Date: Sep 2006
Experience: Techincal support
24-Sep-2006, 01:04 AM #6
Same problem with webcam
I am facing same issue with webcam , it unable to detect driver and usbcamer2.0 error in device manager .
Where can i gert these drivers
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BBBFC1
-08002BE10318}" i never found this registry entry.
Please let me
My computer is not upated to winxp .
scottleibrand's Avatar
scottleibrand scottleibrand is offline
Junior Member with 1 posts.
 
Join Date: Apr 2007
Experience: Einstein
04-Apr-2007, 08:38 PM #7
UpperFilters can cause problems as well
I had these same symptoms on a new Thinkpad. My registry didn't have any LowerFilters values, but I did have an UpperFilters. Deleting it fixed the problem for me.

-Scott
sandrasmurf's Avatar
sandrasmurf sandrasmurf is offline
Junior Member with 1 posts.
 
Join Date: Jul 2007
16-Jul-2007, 04:54 PM #8
Be carefull deleting upper filters
I too have a Thinkpad computer which is never able to properly install sticks, cameras, printers or GPS via USB. Always the "specified service does not exist error."

I registered to warn other people finding this thread first in google.

I unfortunatelly did not see lowerfilters in the registry, but I had the upperfilters as described by scottleibrand above. He had a Thinkpad and the fix for him was to delete the upperfilter values.

Deleting my upperfilter caused a bluescreen after reboot. I was happy that I made a backup of the registry entry before deleting the filter one.

SO REMEMBER TO BACKUP YOUR REGISTRY BEFORE DELETING STUFF.
audioman804's Avatar
audioman804 audioman804 is offline
Junior Member with 1 posts.
 
Join Date: Jul 2007
Experience: Advanced
16-Jul-2007, 10:42 PM #9
Heed the Wizard
Greetings all - I had this problem, searched a bunch of other forums, saw some of the nonsense that deebeeeff was trying to avoid. I can't believe that such a generic problem (who doesn't have USB drives on their keychains now?) has existed since Jan of 2004 and still bites people.

My observation on a customer's Win Home Edition: no Filter keys on any subkeys (0000,0001, etc.). No value in the LowerFilter key - zero length, no data. However, deleting the entire LowerFilter key made my machine recognize USB drives, which it hadn't before.

Although I noted a typo in PC_Wiz' entry (the 4th part of the key isn't BBBFC1 - it's just BFC1 - this may be why kunaladesai could not find the key - I got mine from dbf's log), his advice was outstanding. We all owe PC_Wiz a debt of thanks.

Thanks, PC_Wiz!
Ancient Brit's Avatar
Ancient Brit Ancient Brit is offline
Computer Specs
Junior Member with 1 posts.
 
Join Date: Jul 2007
Experience: Advanced
26-Jul-2007, 10:50 PM #10
Outstanding...
I've been searching for literally months for this solution. I upgraded from Win98SE to XP Pro and it has been a nightmare. When I finally got my system stable again (BSD several times in the process) I decided to upgrade to a larger hard drive - 500G Seagate - and Seagate's software worked very well, creating an image from my smaller original drive (100G Western Digital) that booted first time...

And that's where the problems began. XP kept insisting that it couldn't install the Seagate - despite the fact that it was booting from it *AND* running all the legacy software that made it through the upgrade.

I could NOT get the device manager to install acceptable drivers no matter what I tried and couldn't find anything on Seagate's site that even acknowledged the problem. The yellow alert persisted regardless.

Subsequent problems included an inability to connect my Samsung digital camera reliably (kept disconnecting right in the middle of copying images from camera to PC), an inability to reliably connect not one but two Cruzer II memory sticks (all of these bar the drive were USB and all working perfectly with Win98SE), and a total failure to connect my guitar using a LightSnake cable.

I searched repeatedly for months, usually once a week or so, until I finally came across PC_WIZ's excellent solution. Everything bar the LightSnake works like a dream, and I think I know how to get that sorted. Thank you very much indeed!

What a bizarre solution though. I spent some years as systems manager for a small company and I came across some pretty weird solutions to problems but none quite as obscure as this one.

I wonder whether Mac, Unix, etc., users have to go through this level of crap to solve their problems. Or maybe they don't have them in the first place, because they get to use a decent OS!

Thanks once again - made my day (especially since my wife, who is a non-techie, has been confused by the constant error dialogs every time the system was rebooted. Now I look like a hero But I did give credit where it was due...)

Peter
jayro's Avatar
jayro jayro is offline
Junior Member with 5 posts.
 
Join Date: Aug 2007
Experience: Intermediate
22-Aug-2007, 10:15 AM #11
major issue
ive read several of the forums on this site and many others they pretty much say the same thing ive gotten registry editor followed all the steps people have said.... but in all of them it says find upperfilters and lowerfilters and delete them when i run it and search for the filters niether of them are there???? what should i do?
The_Oracle's Avatar
Computer Specs
Senior Member with 1,562 posts.
 
Join Date: May 2007
Location: Emerald Isle
Experience: is the name we give our m
22-Aug-2007, 11:05 AM #12
Quote:
what should i do?
open your own thread. do not keep posting in a thread, marked as 'solved'.
who-flung-dung's Avatar
who-flung-dung who-flung-dung is offline
Junior Member with 1 posts.
 
Join Date: Feb 2008
Experience: Intermediate
15-Feb-2008, 01:00 PM #13
Just wanted to say "THANKS" you fixed me just like that, hope one day i can help you out
devil_himself's Avatar
Member with 4,910 posts.
 
Join Date: Apr 2007
Location: India
Experience: Advanced
15-Feb-2008, 01:09 PM #14
who-flung-dung, Welcome To TSG
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑