Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Windows XP Windows XP
Search Search
Search for:
Tech Support Guy > > >

Solved: Desktop Icons Slow in Appearing During Boot


(!)

Galleherjazz's Avatar
Galleherjazz Galleherjazz is offline
Member with 371 posts.
THREAD STARTER
 
Join Date: Sep 2002
Location: West New York, NJ 07093
12-Sep-2005, 10:24 PM #1
Unhappy Solved: Desktop Icons Slow in Appearing During Boot
At boot time, my desktop icons take "forever" (1.5 to 2 minutes) to come up--within the last moments of boot-up the icons appear, just when the boot process is complete. I have cut my startup programs to a minimum, pared down the system tray and desktop icons, so don't know what the problem is. I do have NSW and ZA during boot. ZA, as you probably know, seems to take the longest to mount, and it's icon is the last to appear in the system tray.

This slow appearance of the icons is a fairly recent development!

I have researched this on the Internet. I do not believe that I have many system resources devoted to either startup, desktop icons, or system tray icons. Is there any (effective for my purposes) program that helps one to reorder the order of the programs that mount on startup? I found a couple of (non-free) utilities that advertise as capable of changing the boot order. Is there a setting in the System Config Utility that might speed up the boot.

XP, from what I've read, seems to have an endemic problem (after a while) with boot time, both booting up and closing.

There seems to be as many remedies recommended as analgesics for the common cold.

I thought someone might be able to hit on what is causing the slowness on my PC.

Any suggestions guys and gals?
Elvandil's Avatar
Computer Specs
Member with 51,993 posts.
 
Join Date: Aug 2003
Location: Vermont
13-Sep-2005, 12:07 AM #2
You could try Bootvis to analyze your boot process and try to determine the rate-determining steps, as well as any long delays. It can also be used to optimize the boot process by reordering files on the drive, though Microsoft has withdrawn the claim that it will actually improve boot time. It seems to work for me, though I have no quantitative measurements to be sure.

You might check for upgrades to those 2 slow-loading programs (Or did the slowness develop after an upgrade to one of them?).

I use this free program to order the starting of programs on boot, primarily because some applications don't load correctly unless my DNS server has been started previously. Some other applications simply don't load correctly unless they are loaded late in the process.

Startup Delayer

(A delay is not what you want at this point ).

Autoruns will show you all your startup programs and dll's so you may see some there that you don't really need.

Also, defragmenters can change the way items load at startup significantly depending on what method of ordering they choose. If you have more than one defragmenter, try each to see which optimizes the boot process the best. If you use a defragger other than XP's, you may want to disable its boot-optimize function so that the 2 defraggers are not working at cross-purposes:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Dfrg\BootOptimizeFunction

Set "Enable" to "N".

And, have you run a chkdsk /f on all your drives recently? Are you connected to a network?
__________________
Microsoft MVP
異驚の界世 ípןɹoʍ ǝɥʇ ɟo sɹǝpuoʍ ǝɥʇ ɟo ǝuo sı ǝpoɔıun ʞuıɥʇ ı

Last edited by Elvandil; 13-Sep-2005 at 12:17 AM..
Galleherjazz's Avatar
Galleherjazz Galleherjazz is offline
Member with 371 posts.
THREAD STARTER
 
Join Date: Sep 2002
Location: West New York, NJ 07093
13-Sep-2005, 08:18 AM #3
Thank you, Elvandil, I will do all the things you suggest and report back to you.
Elvandil's Avatar
Computer Specs
Member with 51,993 posts.
 
Join Date: Aug 2003
Location: Vermont
13-Sep-2005, 10:40 AM #4
Hopefully, others will have more suggestions. Good luck.
Galleherjazz's Avatar
Galleherjazz Galleherjazz is offline
Member with 371 posts.
THREAD STARTER
 
Join Date: Sep 2002
Location: West New York, NJ 07093
13-Sep-2005, 06:11 PM #5
Thumbs up Issue Resolved Thanks to Elvandil!
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Dfrg\BootOptimizeFunction

Set "Enable" to "N".


Elvandil,

You have pulled the proverbial rabbit right out of the hat! My goodness, I cannot tell you how many things I tried, and your simple little registry change did the trick! The boot time is still longer than I'd like (I think this is the incredibly slow Zone Alarm, which takes forever to mount--the latest version, all updated, has tons of features).

I thought that by disabling Windows defragger that the program wouldn't run. Wrong. It runs just as well as ever! (I use Diskeeper, which, of course, yokes with Windows).

The Welcome screen, which had hung badly now passes almost instantly, and the desktop icons show up right away.

Thanks a million! Tech Support Guy Forums once again triumphs!
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑

Content Relevant URLs by vBSEO 3.3.2