Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Windows XP Windows XP
Search Search
Search for:
Tech Support Guy > > >

Solved: print spooler missing


(!)

museolog's Avatar
museolog museolog is offline
Computer Specs
Member with 36 posts.
THREAD STARTER
 
Join Date: Jan 2008
Experience: Intermediate
13-Jan-2008, 04:40 AM #1
Thumbs down Solved: print spooler missing
Following a new installation of Windows XP Pro, I cannot install a printer. I get the often discussed 'spooler service not running'. But, when I go into the registry, there is no spooler service there. I remember an error during the installation which I now think referred to the non installation of the spooler service, though the message was a bit opaque.

Can I install the spooler separately from anywhere (I can't find a way on the Microsoft website)?

Thanks.
museolog's Avatar
museolog museolog is offline
Computer Specs
Member with 36 posts.
THREAD STARTER
 
Join Date: Jan 2008
Experience: Intermediate
13-Jan-2008, 06:07 AM #2
Found spooler at Ramesh's site: http://windowsxp.mvps.org/spooler.htm but still getting the RPC error. When I open the registry, there is no 'dependany' section in the spooler.

Can anyone offer a fairly straightforward fix for the rpc not available error or do I have to do a full, clean reinstall of XP - I'm not a developer, just an intermediate user.
stantley's Avatar
Computer Specs
Member with 7,009 posts.
 
Join Date: May 2005
Location: Pittsburgh PA USA
Experience: Advanced
13-Jan-2008, 07:40 AM #3
Go to Start > Run, type in services.msc and see what it says about print spooler in there. Look at Properties and check the dependencies.

Also check to make sure Remote Procedure Call is set to automatic and running. Don't make any changes in the registry. Let us know what you find.
museolog's Avatar
museolog museolog is offline
Computer Specs
Member with 36 posts.
THREAD STARTER
 
Join Date: Jan 2008
Experience: Intermediate
13-Jan-2008, 07:50 AM #4
Hi stantley,

Thanks for getting back to me.

Print Spooler Properties: Startup type: Automatic, Local System, Service Status: Stopped.
When I click Start, it produces the following error: Error 23: Data error (cyclic redundancy check)

The RPC Properties are: Started, Automatic, Network Service. The logon is NT AUTHORITYzNetwork Service.

Jim
stantley's Avatar
Computer Specs
Member with 7,009 posts.
 
Join Date: May 2005
Location: Pittsburgh PA USA
Experience: Advanced
13-Jan-2008, 07:57 AM #5
Does Print Spooler have any dependencies other than RPC?
museolog's Avatar
museolog museolog is offline
Computer Specs
Member with 36 posts.
THREAD STARTER
 
Join Date: Jan 2008
Experience: Intermediate
13-Jan-2008, 08:00 AM #6
No, none.
stantley's Avatar
Computer Specs
Member with 7,009 posts.
 
Join Date: May 2005
Location: Pittsburgh PA USA
Experience: Advanced
13-Jan-2008, 08:11 AM #7
See if anything in here might be of some help http://www.pcadvisor.co.uk/forums/in...4341&forumid=1
museolog's Avatar
museolog museolog is offline
Computer Specs
Member with 36 posts.
THREAD STARTER
 
Join Date: Jan 2008
Experience: Intermediate
13-Jan-2008, 09:20 AM #8
I'm afraid I didn't find anything, unless there's a corrupt section on my Hard Drive. If I do a clean renstall of XP Pro, will this solve that problem (if it is actually the problem)

Jim
ozrom1e's Avatar
Computer Specs
Member with 11,849 posts.
 
Join Date: May 2006
Experience: Advanced
13-Jan-2008, 09:33 AM #9
Welcome to TSG....

To download HJTsetup.exe from TrendSecure To Download HijackThis go to the following at the File Repository
Click on the link below to Download HijackThis Self Installer:

http://www.trendsecure.com/portal/en...HJTInstall.exe

Save the file to your desktop.
Double click on the HJTsetup.exe icon on your desktop.
By default it will install to C:\Program Files\HijackThis.
Continue to click Next in the setup dialog boxes until you get to the Select Additional Tasks dialog.
Put a check by Create a desktop icon then click Next again.
Continue to follow the rest of the prompts from there.
At the final dialog box click Finish and it will launch Hijack This.
Click on the Do a system scan and save a log file button. It will scan and then ask you to save the log.
Click Save to save the log file and then the log will open in notepad.
At the top of the Notepad HJT log screen, hit Edit then Select All then click Edit and then click Copy doing that copies the text to the clipboard, you won't see it yet....
Come back here to this thread and Paste the log in your next reply.
DO NOT have Hijack This fix anything yet. Most of what it finds will be harmless or even required.
A security expert with a gold shield to the right of their name should take a look at your log - please be patient.
__________________
I still use my Osborne 01 with a 300 Baud modem all the time.

I was always taught to respect my elders, but it keeps getting harder to find one.

Heaven goes by favorites, If it didn't then your dog would get in first. Amen.
museolog's Avatar
museolog museolog is offline
Computer Specs
Member with 36 posts.
THREAD STARTER
 
Join Date: Jan 2008
Experience: Intermediate
13-Jan-2008, 09:44 AM #10
Hi Ozrom1e

It didn't go through an install process but did launch and do a system scan - follows: (I see at the end "spoolsv.exe (file missing)".

Logfile of Trend Micro HijackThis v2.0.2
Scan saved at 14:40:07, on 13/01/2008
Platform: Windows XP SP2 (WinNT 5.01.2600)
MSIE: Internet Explorer v6.00 SP2 (6.00.2900.2180)
Boot mode: Normal

Running processes:
C:\WINDOWS\System32\smss.exe
C:\WINDOWS\system32\winlogon.exe
C:\WINDOWS\system32\services.exe
C:\WINDOWS\system32\lsass.exe
C:\WINDOWS\system32\svchost.exe
C:\WINDOWS\System32\svchost.exe
C:\WINDOWS\Explorer.EXE
C:\Program Files\Google\Common\Google Updater\GoogleUpdaterService.exe
C:\Program Files\Common Files\Microsoft Shared\VS7DEBUG\MDM.EXE
c:\Program Files\Sophos\Sophos Anti-Virus\SAVAdminService.exe
c:\Program Files\Sophos\AutoUpdate\ALsvc.exe
C:\WINDOWS\system32\svchost.exe
C:\Program Files\Common Files\Real\Update_OB\realsched.exe
C:\WINDOWS\SOUNDMAN.EXE
C:\WINDOWS\system32\ctfmon.exe
C:\Program Files\Sophos\AutoUpdate\ALMon.exe
C:\Program Files\Google\Google Updater\GoogleUpdater.exe
C:\Program Files\Internet Explorer\IEXPLORE.EXE
C:\Program Files\Internet Explorer\IEXPLORE.EXE
C:\Program Files\Internet Explorer\IEXPLORE.EXE
C:\Program Files\Internet Explorer\IEXPLORE.EXE
C:\Program Files\Microsoft Office\OFFICE11\WINWORD.EXE
F:\setup.exe
C:\Program Files\Trend Micro\HijackThis\HijackThis.exe

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.le.ac.uk/ms/
O2 - BHO: Adobe PDF Reader Link Helper - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelper.dll
O2 - BHO: RealPlayer Download and Record Plugin for Internet Explorer - {3049C3E9-B461-4BC5-8870-4C09146192CA} - C:\Program Files\Real\RealPlayer\rpbrowserrecordplugin.dll
O2 - BHO: Google Toolbar Helper - {AA58ED58-01DD-4d91-8333-CF10577473F7} - c:\program files\google\googletoolbar2.dll
O2 - BHO: Google Toolbar Notifier BHO - {AF69DE43-7D58-4638-B6FA-CE66B5AD205D} - C:\Program Files\Google\GoogleToolbarNotifier\2.1.1119.1736\swg.dll
O3 - Toolbar: &Google - {2318C2B1-4965-11d4-9B18-009027A5CD4F} - c:\program files\google\googletoolbar2.dll
O4 - HKLM\..\Run: [Adobe Reader Speed Launcher] "C:\Program Files\Adobe\Reader 8.0\Reader\Reader_sl.exe"
O4 - HKLM\..\Run: [TkBellExe] "C:\Program Files\Common Files\Real\Update_OB\realsched.exe" -osboot
O4 - HKLM\..\Run: [QuickTime Task] "C:\Program Files\QuickTime\QTTask.exe" -atboottime
O4 - HKLM\..\Run: [SoundMan] SOUNDMAN.EXE
O4 - HKCU\..\Run: [swg] C:\Program Files\Google\GoogleToolbarNotifier\GoogleToolbarNotifier.exe
O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\system32\ctfmon.exe
O4 - HKUS\S-1-5-19\..\Run: [CTFMON.EXE] C:\WINDOWS\system32\CTFMON.EXE (User 'LOCAL SERVICE')
O4 - HKUS\S-1-5-20\..\Run: [CTFMON.EXE] C:\WINDOWS\system32\CTFMON.EXE (User 'NETWORK SERVICE')
O4 - HKUS\S-1-5-18\..\Run: [CTFMON.EXE] C:\WINDOWS\system32\CTFMON.EXE (User 'SYSTEM')
O4 - HKUS\.DEFAULT\..\Run: [CTFMON.EXE] C:\WINDOWS\system32\CTFMON.EXE (User 'Default user')
O4 - Startup: Adobe Gamma.lnk = C:\Program Files\Common Files\Adobe\Calibration\Adobe Gamma Loader.exe
O4 - Global Startup: Adobe Gamma Loader.exe.lnk = C:\Program Files\Common Files\Adobe\Calibration\Adobe Gamma Loader.exe
O4 - Global Startup: AutoUpdate Monitor.lnk = C:\Program Files\Sophos\AutoUpdate\ALMon.exe
O4 - Global Startup: Google Updater.lnk = C:\Program Files\Google\Google Updater\GoogleUpdater.exe
O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~2\OFFICE11\EXCEL.EXE/3000
O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MICROS~2\OFFICE11\REFIEBAR.DLL
O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
O15 - Trusted Zone: http://www.msi.com.tw
O16 - DPF: {0A5FD7C5-A45C-49FC-ADB5-9952547D5715} (Creative Software AutoUpdate) - http://www.creative.com/su/ocx/15031/CTSUEng.cab
O16 - DPF: {8167C273-DF59-4416-B647-C8BB2C7EE83E} (WebSDev Control) - http://liveupdate.msi.com.tw/autobio...ne/install.cab
O16 - DPF: {F6ACF75C-C32C-447B-9BEF-46B766368D29} (Creative Software AutoUpdate Support Package) - http://www.creative.com/su/ocx/15034/CTPID.cab
O20 - AppInit_DLLs: c:\PROGRA~1\Sophos\SOPHOS~1\SOPHOS~1.DLL
O23 - Service: Adobe LM Service - Adobe Systems - C:\Program Files\Common Files\Adobe Systems Shared\Service\Adobelmsvc.exe
O23 - Service: Google Updater Service (gusvc) - Google - C:\Program Files\Google\Common\Google Updater\GoogleUpdaterService.exe
O23 - Service: Sophos Anti-Virus status reporter (SAVAdminService) - Sophos Plc - c:\Program Files\Sophos\Sophos Anti-Virus\SAVAdminService.exe
O23 - Service: Sophos Anti-Virus (SAVService) - Sophos Plc - c:\Program Files\Sophos\Sophos Anti-Virus\SavService.exe
O23 - Service: Sophos AutoUpdate Service - Sophos Plc - c:\Program Files\Sophos\AutoUpdate\ALsvc.exe
O23 - Service: Print Spooler (Spooler) - Unknown owner - C:\WINDOWS\system32\spoolsv.exe (file missing)

Jim
museolog's Avatar
museolog museolog is offline
Computer Specs
Member with 36 posts.
THREAD STARTER
 
Join Date: Jan 2008
Experience: Intermediate
19-Jan-2008, 01:05 PM #11
It seemed that the only solution was to do a clean reinstall of Windows XP Professional and then reinstall the printer from the original software (which I eventually found) - it still would not install from the web.

Thanks to all who tried to help.

Jim
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑

Content Relevant URLs by vBSEO 3.3.2