Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Windows XP Windows XP
Search Search
Search for:
Tech Support Guy > > >

Solved: Print Spooler will not start. Error 2.


(!)

Palladia-Mors's Avatar
Palladia-Mors Palladia-Mors is offline
Computer Specs
Member with 158 posts.
THREAD STARTER
 
Join Date: Apr 2008
Experience: Beginner
05-Aug-2010, 04:22 PM #1
Solved: Print Spooler will not start. Error 2.
Hello, I am trying to install my new Canon Pixma MP 330 printer, and cannot install its software because of this error:
"Processing cannot be continued because the Print Spooler Service has been stopped."

It told me to restart so I restarted, which did not start the Print Spooler. I went to manage services and tried to start the Print Spooler, where it gave me "Error 2: The system cannot find the file specified."

I looked up its properties, where I found that it is set to Automatic. The Print Spooler depends on Remote Procedure Call (RPC), and hpdj00 depends on the Print Spooler.

HP deskjet 5700 series was my old printer. I already uninstalled all of the HP Deskjet and Officejet software using its uninstallers, and I force uninstalled it all again using RevoProUninstaller. After the uninstalling and restarting, I still cannot start the Print Spooler, and continue to see the hpdj00 dependency and Error 2.


I can think of two possible explanations:
1. In uninstalling the HP printer software and deleting the leftover folders, I accidentally deleted a Print Spooler file that I need. Everything can be reinstalled from the HP CD or restored from the recycle bin, so this should be reversible.
2. Some piece of HP printer software is STILL on my computer, disabling the Print Spooler.


I have an HP Pavillion a1101n, Windows XP Home SP3.

The HP printer programs I uninstalled are: HP PSC & OfficeJet 4.7
HP Deskjet 5700 Series
HP Deskjet Printer Preload

Thank you!

Last edited by Palladia-Mors; 05-Aug-2010 at 05:44 PM..
stantley's Avatar
Computer Specs
Member with 7,009 posts.
 
Join Date: May 2005
Location: Pittsburgh PA USA
Experience: Advanced
05-Aug-2010, 06:06 PM #2
Make sure all of these files are in C:\WINDOWS\system32

spoolsv.exe
spoolss.dll
localspl.dll
win32spl.dll
winspool.drv
tcpmon.dll
tcpmib.dll
usbmon.dll

http://www.pcreview.co.uk/forums/thread-554874.php

You might want to clean up the old drivers:

http://members.shaw.ca/bsanders/CleanPrinterDrivers.htm
Palladia-Mors's Avatar
Palladia-Mors Palladia-Mors is offline
Computer Specs
Member with 158 posts.
THREAD STARTER
 
Join Date: Apr 2008
Experience: Beginner
05-Aug-2010, 08:24 PM #3
spoolsv.exe: NO! I am running a search for it. Is there any possibility that the HP Diskjet uninstallers or RevoProUninstaller removed it?

spoolss.dll: Yes
localspl.dll: Yes
win32spl.dll: Yes
winspool.drv: Yes, plus Winspool.exe "loaded as Winspool.drv"
tcpmon.dll: Yes
tcpmib.dll: Yes
usbmon.dll: Yes


The search for spoolsv turned up three files:

spoolsv.exe in C:\WINDOWS\$NtServicePackUninstall$
SPOOLSV.EX_ in C:\WINDOWS\I386
spoolsv.exe in C:\WINDOWS\ServicePackFiles\i386

Is it possible to copy one of those into my system32 file? Or is SPOOLSV.EX_ a damaged file?
vicks's Avatar
Computer Specs
Member with 5,122 posts.
 
Join Date: Jan 2005
Location: Nebraska
Experience: Intermediate
05-Aug-2010, 08:57 PM #4
I would try to completely uninstall all remenants of the previous installation, then reboot the computer and reinstall the software/drivers from the printer's cd.
vicks
stantley's Avatar
Computer Specs
Member with 7,009 posts.
 
Join Date: May 2005
Location: Pittsburgh PA USA
Experience: Advanced
05-Aug-2010, 09:19 PM #5
Go to Start > Run type cmd

Then type this:

Expand C:\WINDOWS\I386\SPOOLSV.EX_ c:\windows\system32\spoolsv.exe
Palladia-Mors's Avatar
Palladia-Mors Palladia-Mors is offline
Computer Specs
Member with 158 posts.
THREAD STARTER
 
Join Date: Apr 2008
Experience: Beginner
06-Aug-2010, 04:09 PM #6
spoolsv.exe is now in place in the system32 folder and I got to start the Print Spooler Service, so this is progress. But the printer still won't install properly (it got further into install, but now gives me a different error: "Windows could not load the installer for Image."). The tech support people at Canon told me my Print Spooler is corrupt!
stantley's Avatar
Computer Specs
Member with 7,009 posts.
 
Join Date: May 2005
Location: Pittsburgh PA USA
Experience: Advanced
06-Aug-2010, 06:35 PM #7
Try using the copy that's in C:\WINDOWS\ServicePackFiles\i386 and see if that makes any difference.
Palladia-Mors's Avatar
Palladia-Mors Palladia-Mors is offline
Computer Specs
Member with 158 posts.
THREAD STARTER
 
Join Date: Apr 2008
Experience: Beginner
06-Aug-2010, 08:41 PM #8
Can I just copy and paste the one in i386, or do I need to expand it?
stantley's Avatar
Computer Specs
Member with 7,009 posts.
 
Join Date: May 2005
Location: Pittsburgh PA USA
Experience: Advanced
06-Aug-2010, 09:04 PM #9
Yes, you can just copy it.

The ones you have to expand are only when the file extension has an underscore at the end (.ex_)
Palladia-Mors's Avatar
Palladia-Mors Palladia-Mors is offline
Computer Specs
Member with 158 posts.
THREAD STARTER
 
Join Date: Apr 2008
Experience: Beginner
07-Aug-2010, 11:45 AM #10
Thank you for your help so far... the stupid Print Spooler STILL doesn't work! Is there some other program or registry entry or something that could have been deleted by the HP DeskJet uninstaller?

How do I expand the compressed spoolsv.exe copy inside C:\WINDOWS\$NtServicePackUninstall$ ? I copy-pasted it and the new copy doesn't look compressed (isn't blue).

Nope, I still get the same error: "Windows could not load the installer for Image." I guess all the SPs that came for XP were all corrupt to begin with.



Any idea what I need to do next? Will fixing this require the original Windows install CDs (they were never given to me)? Should I run clnspool? Delete every print spooler and download new Service Packs? Is it a virus?

Last edited by Palladia-Mors; 07-Aug-2010 at 12:04 PM..
stantley's Avatar
Computer Specs
Member with 7,009 posts.
 
Join Date: May 2005
Location: Pittsburgh PA USA
Experience: Advanced
07-Aug-2010, 01:00 PM #11
Yes, I would run a virus scan and an anti-malware scan to be on the safe side. Post a HiJackThis log and I'll see if any problems show up there.

Go to this site http://www.trendsecure.com/portal/en...?page=download.

Click on 'Download HijackThis Installer'.

*Save HJTInstall.exe to your desktop, or to the location where you normally download.
*Double-click on HJTInstall.exe.
*Click on Install.
*By default it will install to C:\Program Files\Trend Micro\HijackThis.
*Once installed, it will launch Hijackthis.
*Click on the 'Do a system scan and save a logfile button'. It will scan and the log will open in Notepad.
*In Notepad go to Format and make sure 'Word Wrap' is not checked.
*Click on 'Edit > Select All' then click on 'Edit > Copy' (or Ctrl-C) to copy the entire contents of the log.
*Come back to this thread and Paste (or Ctrl-V) the log in your next reply.

*DO NOT have HijackThis fix anything yet. Most of what it finds will be harmless or even required.
Palladia-Mors's Avatar
Palladia-Mors Palladia-Mors is offline
Computer Specs
Member with 158 posts.
THREAD STARTER
 
Join Date: Apr 2008
Experience: Beginner
08-Aug-2010, 05:47 PM #12
OK, the AVG scan turned up no malware. Here's the Hijack This log:


Logfile of Trend Micro HijackThis v2.0.4
Scan saved at 5:44:59 PM, on 8/8/2010
Platform: Windows XP SP3 (WinNT 5.01.2600)
MSIE: Internet Explorer v8.00 (8.00.6001.18702)
Boot mode: Normal

Running processes:
C:\WINDOWS\System32\smss.exe
C:\WINDOWS\system32\winlogon.exe
C:\WINDOWS\system32\services.exe
C:\WINDOWS\system32\lsass.exe
C:\WINDOWS\system32\svchost.exe
C:\WINDOWS\System32\svchost.exe
C:\Program Files\AVG9\avgchsvx.exe
C:\Program Files\AVG9\avgrsx.exe
C:\Program Files\AVG9\avgcsrvx.exe
C:\WINDOWS\system32\spoolsv.exe
C:\Program Files\Common Files\Apple\Mobile Device Support\bin\AppleMobileDeviceService.exe
C:\Program Files\AVG9\avgwdsvc.exe
C:\Program Files\Common Files\Microsoft Shared\VS7DEBUG\MDM.EXE
C:\Program Files\AVG9\avgnsx.exe
C:\WINDOWS\Explorer.EXE
C:\PROGRA~1\AVG9\avgtray.exe
C:\Program Files\Mozilla Firefox\firefox.exe
C:\Program Files\NETGEAR\WG311v3\WG311v3.exe
C:\WINDOWS\system32\msiexec.exe
C:\Program Files\Trend Micro\HijackThis\HiJackThis.exe

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://ie.redirect.hp.com/svs/rdr?TY...ion&pf=desktop
R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Bar = http://ie.redirect.hp.com/svs/rdr?TY...ion&pf=desktop
R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Page = http://ie.redirect.hp.com/svs/rdr?TY...ion&pf=desktop
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Bar = http://ie.redirect.hp.com/svs/rdr?TY...ion&pf=desktop
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant = http://ie.redirect.hp.com/svs/rdr?TY...ion&pf=desktop
O2 - BHO: AcroIEHelperStub - {18DF081C-E8AD-4283-A596-FA578C2EBDC3} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelperShim.dll
O2 - BHO: WormRadar.com IESiteBlocker.NavFilter - {3CA2F312-6F6E-4B53-A66E-4E65E497C8C0} - C:\Program Files\AVG9\avgssie.dll
O2 - BHO: NCO 2.0 IE BHO - {602ADB0E-4AFF-4217-8AA1-95DAC4DFA408} - (no file)
O2 - BHO: Java(tm) Plug-In 2 SSV Helper - {DBC80044-A445-435b-BC74-9C25C1C588A9} - C:\Program Files\Java\jre6\bin\jp2ssv.dll
O3 - Toolbar: HP View - {B2847E28-5D7D-4DEB-8B67-05D28BCF79F5} - c:\Program Files\HP\Digital Imaging\bin\HPDTLK02.dll
O3 - Toolbar: (no name) - {7FEBEFE3-6B19-4349-98D2-FFB09D4B49CA} - (no file)
O4 - HKLM\..\Run: [AVG9_TRAY] C:\PROGRA~1\AVG9\avgtray.exe
O4 - HKLM\..\Run: [KernelFaultCheck] %systemroot%\system32\dumprep 0 -k
O4 - HKLM\..\Run: [Adobe Reader Speed Launcher] "C:\Program Files\Adobe\Reader 9.0\Reader\Reader_sl.exe"
O4 - HKLM\..\Run: [Adobe ARM] "C:\Program Files\Common Files\Adobe\ARM\1.0\AdobeARM.exe"
O4 - Global Startup: NETGEAR WG311v3 Smart Wizard.lnk = C:\Program Files\NETGEAR\WG311v3\WG311v3.exe
O8 - Extra context menu item: Add To HP Organize... - C:\PROGRA~1\HEWLET~1\HPORGA~1\bin/module.main/favorites\ie_add_to.html
O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MI1933~1\OFFICE11\EXCEL.EXE/3000
O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MI1933~1\OFFICE11\REFIEBAR.DLL
O9 - Extra button: Connection Help - {E2D4D26B-0180-43a4-B05F-462D6D54C789} - C:\WINDOWS\PCHEALTH\HELPCTR\Vendors\CN=Hewlett-Packard,L=Cupertino,S=Ca,C=US\IEButton\support.htm
O9 - Extra 'Tools' menuitem: Connection Help - {E2D4D26B-0180-43a4-B05F-462D6D54C789} - C:\WINDOWS\PCHEALTH\HELPCTR\Vendors\CN=Hewlett-Packard,L=Cupertino,S=Ca,C=US\IEButton\support.htm
O9 - Extra button: (no name) - {e2e2dd38-d088-4134-82b7-f2ba38496583} - C:\WINDOWS\Network Diagnostic\xpnetdiag.exe
O9 - Extra 'Tools' menuitem: @xpsp3res.dll,-20001 - {e2e2dd38-d088-4134-82b7-f2ba38496583} - C:\WINDOWS\Network Diagnostic\xpnetdiag.exe
O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
O9 - Extra button: Connection Help - {E2D4D26B-0180-43a4-B05F-462D6D54C789} - C:\WINDOWS\PCHEALTH\HELPCTR\Vendors\CN=Hewlett-Packard,L=Cupertino,S=Ca,C=US\IEButton\support.htm (HKCU)
O9 - Extra 'Tools' menuitem: Connection Help - {E2D4D26B-0180-43a4-B05F-462D6D54C789} - C:\WINDOWS\PCHEALTH\HELPCTR\Vendors\CN=Hewlett-Packard,L=Cupertino,S=Ca,C=US\IEButton\support.htm (HKCU)
O18 - Protocol: linkscanner - {F274614C-63F8-47D5-A4D1-FBDDE494F8D1} - C:\Program Files\AVG9\avgpp.dll
O20 - Winlogon Notify: avgrsstarter - avgrsstx.dll (file missing)
O22 - SharedTaskScheduler: Browseui preloader - {438755C2-A8BA-11D1-B96B-00A0C90312E1} - C:\WINDOWS\system32\browseui.dll
O22 - SharedTaskScheduler: Component Categories cache daemon - {8C7461EF-2B13-11d2-BE35-3078302C2030} - C:\WINDOWS\system32\browseui.dll
O23 - Service: Apple Mobile Device - Apple Inc. - C:\Program Files\Common Files\Apple\Mobile Device Support\bin\AppleMobileDeviceService.exe
O23 - Service: AVG Free WatchDog (avg9wd) - AVG Technologies CZ, s.r.o. - C:\Program Files\AVG9\avgwdsvc.exe
O23 - Service: InstallDriver Table Manager (IDriverT) - Macrovision Corporation - C:\Program Files\Common Files\InstallShield\Driver\11\Intel 32\IDriverT.exe
O23 - Service: iPod Service - Apple Inc. - C:\Program Files\iPod\bin\iPodService.exe
O23 - Service: Pml Driver HPZ12 - HP - C:\WINDOWS\system32\HPZipm12.exe
O23 - Service: Windows User Mode Driver Framework (UMWdf) - Unknown owner - C:\WINDOWS\system32\wdfmgr.exe (file missing)

--
End of file - 6147 bytes
stantley's Avatar
Computer Specs
Member with 7,009 posts.
 
Join Date: May 2005
Location: Pittsburgh PA USA
Experience: Advanced
08-Aug-2010, 06:20 PM #13
I'm not a malware expert but from what I can see your computer is clean. I would reinstall the HP printer software and then uninstall it (hopefully getting a clean uninstall). Reboot and then follow the steps to clean up printer drivers here:

http://members.shaw.ca/bsanders/CleanPrinterDrivers.htm

Reboot and then try installing the Canon software.
vicks's Avatar
Computer Specs
Member with 5,122 posts.
 
Join Date: Jan 2005
Location: Nebraska
Experience: Intermediate
08-Aug-2010, 07:37 PM #14
AVG is an antivirus program. You also should run superantispyware and Malwarebytes anti malware to be sure there aren't some other bad guys, running on you computer..Both are free and available at www.majorgeeks.com or www.download.com, or www.filehippo.com. There is sooo much bad stuff circulating that it is pretty much impossible for one to catch everything.
Good Luck
Vicks
Palladia-Mors's Avatar
Palladia-Mors Palladia-Mors is offline
Computer Specs
Member with 158 posts.
THREAD STARTER
 
Join Date: Apr 2008
Experience: Beginner
16-Aug-2010, 09:08 PM #15
Hi all, I made one last stab at getting my printer installed without re-installing and uninstalling the old one, and after only installing the driver and not the rest of the software, got the Cannon printer to print! So a huge thank you to everybody who helped me get the Print Spooler service re-started.

The Cannon scanner software seems to be what is still screwwed up, not the Print Spooler or the printer driver.

Regarding the spyware and AVG, my computer previously had separate spyware and virus scanners, and they attacked each other all the time and made my computer horribly slow. I prefer not to go down that road again now that my computer functions at a more reasonable speed.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


Similar Threads
Title Thread Starter Forum Replies Last Post
error 1053 + Print spooler rosie10 Windows XP 0 01-May-2010 11:17 PM
Print Spooler Won't Start (Error 1053) sixthcrusifix Windows XP 15 28-Oct-2009 03:45 PM
Solved: satellite a135 s4467 will not start/will not boot dlangy123 Hardware 13 01-Oct-2009 11:32 AM
Print Spooler - PLEASE HELP surfinggrom Windows Vista 2 10-Jul-2008 06:21 AM
print spooler will not start/ print subsystem is unavalible ladywolf Windows XP 1 14-Sep-2007 08:26 PM

WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑