144hz feels choppy/teary after new cpu cooler installation

japxeet

Thread Starter
Joined
Sep 16, 2021
Messages
1
My PC specs:

AMD Ryzen 5 5600X

AMD RX 6700XT GPU

16GB DDR4

Dark Rock Slim CPU FAN

Viewsonic VX2458 144hz monitor.





I was using my stock CPU cooler for a while and started noticing CPU temps rising and a little throttle, so I decided to change my cooler to the current Dark Rock Slim, my temps dropped and everything else is fine but my 144hz feels choppy when I play, even though I get 300+ FPS, i've tried it on rainbow six siege, CSGO, splitgate. The mouse movement on desktop and other apps feel like 144hz, but the game doesnt feel like a proper 144hz experience, it feels better than 60hz but still choppy and teared when I move my mouse, Im wondering what could the reason be, everything was working fine before I upgraded my fan, Could it be that I messed up the GPU or the CPU somehow? Do I need to take everything out and rebuild my system? I've been going crazy, I built this PC specifically for 144hz gaming but watching it lag just makes me sad. (Everything was working perfect before the fan upgrade, Same CPU Same Monitor Same Displayport Wire) I even went and bought a new DP wire and its still the same. Any help would be appreciated!



Benchmark: https://www.userbenchmark.com/UserRun/46303012
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top