1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

2 different networks, WAN and LAN on 1PC?

Discussion in 'Networking' started by TakuSkan, Jul 2, 2009.

Thread Status:
Not open for further replies.
Advertisement
  1. TakuSkan

    TakuSkan Thread Starter

    Joined:
    Feb 16, 2005
    Messages:
    26
    I initially thought I had resolved this last December in this post, but am now having issues related to remote file sharing.

    I've got 1 WAN and 1 LAN network set up. The WAN router is set to an IP of 192.168.1.1 which must remain. I've set the LAN to an IP of 192.168.2.1.

    I have a notebook running Vista where the WAN adapter connection is set to obtain the IP address automatically. Its LAN connection is set to the custom IP of 192.168.2.1, subnet mask of 255.255.255.0, and no default gateway as instructed by zx10guy to enable access to both networks simultaneously.

    However I've just discovered that the notebook is using the WAN to transfer files to the PC tower that now has Windows 7 beta 7100 installed. I don't know if the problem existed prior to the switch to Win7 on that system.

    The way Win7 deals with security for network connections seems to be different from Vista in how it deals with a 'Private Network' and a 'Public Network' through its new firewall and file sharing functions. And I must confess, I don't know much about these things.

    The IP settings for WAN and LAN in Win7 on the tower are set up as they are on the notebook running Vista SP1. But the two systems will only access both the Internet and remote file sharing via WAN.

    And the WAN adapter on the tower running Win7 has to be set to a 'Public Network' connection type in order to access both, where the notebook can access both with its WAN set to either private or public.

    With the tower's LAN adapter connection set to a specific IP as it is, Win7 does not allow setting it as a 'Private Network' type. I wondered if I could get remote file sharing enabled if I could get the LAN set to a 'Private Network'.

    So I tried setting the LAN to obtain the IP automatically which allow it to changed to a 'Private Network' type, and assigning the IP for the WAN to 192.168.2.45, subnet mask of 255.255.255.0, and default gateway 192.168.1.1. But that results in no access to either Internet or remote shared files. That would have caused problems anyway if the WAN IP was switched by the router remotely when the system was shut down, and rebooted later.

    I've tried a few other things, but have failed to get both systems to access the Internet via WAN as they must, and enable remote file sharing via LAN between these systems.

    Thanks for any feedback

    TS

    Edit: It seems the default network being automatically set to 192.168.2.1 in the WAN settings may be at the root of this problem. But I stil can't figure out how to get things working from here.
     
  2. zx10guy

    zx10guy Trusted Advisor Spam Fighter

    Joined:
    Mar 30, 2008
    Messages:
    6,013
    What's the IP of the Win 7 box?

    You can't set an IP of 192.168.2.x with a subnet mask of 255.255.255.0 and use a default gateway of 192.168.1.1. The interesting octet for both number is the 3rd one which states .2 is on one subnet and .1 is on another. Did you put the Win 7 box ont he 192.168.2.x subnet?
     
  3. TakuSkan

    TakuSkan Thread Starter

    Joined:
    Feb 16, 2005
    Messages:
    26
    Edit: Note comment in red below.

    WAN is 192.168.1.45
    LAN is 192.168.2.4

    Do you mean did I set the subnet >mask< to 192.168.2.x? If so, no. If you mean there's some way to set a subnet value outside of the WAN adapter settings not related to the adapter's 'subnet mask' setting, I don't know anything about that. But I would guess that would involve WAN settings in the router which I don't have control over.

    As I wrote above, when I tried to set an IP address for the WAN manually in Win7 on the tower, I used an IP of 192.168.2.45 (WHOOPS - THAT SHOULD READ 192.168.1.45 BOTH HERE AND ABOVE) subnet mask of 255.255.255.0, and default gateway 192.168.1.1 which is what ipconfig is reporting for the WAN connection when it's working.

    I didn't try a 'defaut gateway' of 192.168.2.4. But I just tried doing that and got a popup waring saying:
    "The default gateway is not the same on the network segment (subnet) that is defined by the IP address and subnet mask. Do you want to save this configuration?"​
    If I go ahead and click yes to set it, the WAN looses the network connection and I get an IP conflict popup and the connection fails.

    I just discovered I didn't have 'Network Discovery' enabled in the 'Advanced sharing settings' of 'Network and Sharing Center' in Win7. It wasn't required for remote file sharing with the WAN adapter for some reason before adding the LAN hardware. But changing that didn't enable remote file sharing via LAN. That's still going through the WAN.

    I'm thinking this may be a Win7 problem though as I just confirmed the notebook does transfer files via the LAN on IP 192.168.2.x to a different PC here that's running Vista.
     
  4. zx10guy

    zx10guy Trusted Advisor Spam Fighter

    Joined:
    Mar 30, 2008
    Messages:
    6,013
    The issue you have here is that both boxes can see each other on either network. And what is happening here is it appears the OS is picking a preferential interface to communicate to the new box. This would be an OS configuration issue now. I would try to see if you can set the NIC for 192.168.2.x to be the first perferred NIC. Here's a link I found which may help to see if this will solve your problem.

    http://support.microsoft.com/kb/894564

    Focus particularly on the section which talks about setting the interface metric on a network adapter. Other than that, you'll have to see if some of the other guys here can help out in configuring Windows as that's my weak point.

    You may also look into changing the binding order of the NICs.
     
  5. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    The easiest method is changing the binding order, which is clearly described in the link that zx10guy posted. I'd try that first.
     
  6. TakuSkan

    TakuSkan Thread Starter

    Joined:
    Feb 16, 2005
    Messages:
    26
    Thanks folks. The section on binding order at the top of that MS support page did the trick, and was a simple and relatively mindless task. I'm not entirely clear on what bindings are and how they operate. But I'm glad that fixed the problem as the rest of that support page was pretty much &#945;&#946;&#916;&#931;&#963;&#936;&#956;&#950; to me.

    I am a bit concerned about security on the WAN side of things now having discovered the system has been using it for remote file sharing. I'd like to block all other IP addresses associated with the WAN running on 192.168.1.x with Win7's firewall.

    That used to be an easy task for ZoneAlarm, the only firewall I've ever hand a basic handle on. By default ZoneAlarm blocked all IP addresses on the local network, and I'd just enter the ones I wanted to allow communication with.

    But Check Point hasn't yet developed a version for Win7. Does anyone know how to address that with Win7's new firewall?

    I now see that the fact the WAN connection being set as a 'Public network' in 'Network and Sharing Center' didn't block remote file sharing, which is interesting.
     
  7. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    If you want to block access from any other 192.168.1.x location, just turn off file/print sharing totally.

    Remove file sharing is by definition a WAN activity, which would take place outside your network. With your network defined as a public network, file and print sharing is disabled on your machine.
     
  8. TakuSkan

    TakuSkan Thread Starter

    Joined:
    Feb 16, 2005
    Messages:
    26
    Ah yes... Network Connections > Advanced > Advanced Settings > uncheck 'File and Printer Sharing for Microsoft Networks' for the WAN adapter. I've forgotten about that. I'll try it.

    Unfortunately that was not the case here, and I wonder why. In those 'Advanced Settings' I mentioned above, I found 'File and Printer Sharing for Microsoft Networks' enabled for both the WAN and LAN adapters when I 1st looked at it. And they're both set as 'Public Networks'.

    The fact that networking in the Win7 OS on the PC tower was using the WAN to transfer files via remote file sharing was the root of this issue to begin with. As I wrote in my 1st post:
    "... the two systems will only access both the Internet and remote file sharing via WAN.

    And the WAN adapter on the tower running Win7 has to be set to a 'Public Network' connection type in order to access both, where the notebook can access both with its WAN set to either private or public."​

    What I found on the notebook seems to contradict what you were saying too unless I'm not understanding what you're saying.

    During the Win7 installation on the tower, the LANs and WANs were detected and I was prompted to specify 'public' or 'private' for each. I set 'public' for the WAN, and 'private' for the LAN.

    But on completion of the OS installation, the Internet was being blocked. At this point I'm pretty familar with the issue with the 'default gateway' that zx10guy originally pointed out in this same basic thread last December. I went into 'Network Connections' and set the IP for the LAN to 192.168.2.4 manually, and left 'Default Gateway' blank, which enabled Internet access via WAN.

    But at some point I noticed a problem with transfering files via the LAN, and found the issue I was originally addressing here where the WAN was being used instead of the LAN.

    I also found that after manually setting 192.168.2.4 for the LAN, it got changed from a 'Private Network' to a 'Public Network' in the 'Network and Sharing Center'. And its designation was changed from 'Network' to an 'Unidentified Network'. The WAN was set as a 'Public Network' as I had selected during Win7 installation, thinking that would block file sharing.

    My 1st instinct was to switch the LAN from public to a private one, but found that option wasn't available. In Win7 each active network has either a 'Public Network' or a 'Private Network' hyperlink in 'Network and Sharing Center' to change the network type if it's available. But the LAN's hyperlink is disabled (grayed out, or blacked out in this case'). For some reason that was caused by setting the IP address manually, and I never figured out how to get around that. I'd like to change that, but maybe that's a question for the Win7 forums.
     
  9. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    I think the restriction for "public networks" is in the firewall.
     
  10. TakuSkan

    TakuSkan Thread Starter

    Joined:
    Feb 16, 2005
    Messages:
    26
    Technically that's probably where the changes go. However in Vista the setting can be changed quickly via the 'customize' hyperlink in 'Network and Sharing Center'. And in Win7 via either the 'Public network' or 'Private network' hyperlink, whichever appears for each active network.

    I'm posting a message to the Win7 support forum to address why files were being shared via the WAN as a 'Public network'. And how I might change the LAN setting to a 'Private network'.
     
  11. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/840082

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice