1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

2nd Video Card dying...

Discussion in 'Hardware' started by icepick099, Mar 27, 2008.

Thread Status:
Not open for further replies.
  1. icepick099

    icepick099 Thread Starter

    Joined:
    Mar 27, 2008
    Messages:
    1
    Hello, first time poster here, long-time "making my own computer" type guy.

    I built two (almost) identical PCs:

    MSI 975X motherboard
    2GB Kingston DDR2 800 RAM
    ATI Radeon x1950 Pro 512 MB PCI-Express
    400GB Seagate

    Difference between the two PCs is the power supply. One was an Antec Earthwatt 500W power supply, the other was an Antec (not-earthwatt) 430W, both with those 12V rails made for the new video cards.

    About 6 months ago, I noticed on PC#1 (500W Earthwatt), that the graphics while running some online game (think WoW or Vanguard or something) started getting "stretchy." The best way to desribe it is:

    Picture the very center of the screen - whatever color that pixel is, stretched radially from the center to a side of the screen in an arc. It then would spin around the screen. You could see the graphics you needed to, but there was this constant "slice-of-pie" shaped anomaly that would flash around the screen very often.

    Mind you, this does not happen if the PC is only being used for browsing the web, answering emails, watching videos on youtube, watching a DVD, etc. I'd assume its only when the card is under stress from graphic-intensive things.

    When this happened, I tried replacing drivers, I yanked the card out and dusted it off with an airspray duster, and ran the airspray over the contacts of the card and the motherboard. That made no difference.

    At this point, I swapped cards between the computers. I figured maybe there was a problem with the motherboard on PC#1. But, the card from PC#2 functioned fine, but the card from PC#1 still exhibited the same issues. So, I wrote the card off as badly manufactured, and purchased another card (same model, but made by Sapphire instead of ATI). I kept the "good card" in PC#1 and put the new video card in PC#2.

    Flash-forward to today. The "good card" that was in PC#1 is also showing this same problem. So, that says to me that there is a problem with PC#1, and not the card itself (well, the problem was caused by PC#1 - the card itself is no good now).

    I'm kicking around some ideas on where to go next with this. Could it be the motherboard in PC#1? Could it be the power supply? Could it be the PCI-Express power connector from the power supply? Should I try using the other power connector in that power supply?

    Whatever it is, that PC is frying perfectly good cards. Regardless, I need to replace the card for the time being. But, in order to mitigate costs, I figured replace either the power supply or the motherboard. Obviously, replacing just the card is going to result in yet another fried card.

    I was also thinking if I should try swapping power supplies instead. Put PC#1's power supply in PC#2, and use a different power connector for the video card. If PC#1's new card dies, it was PC#1's motherboard. If the card in PC#2 dies, then it was the power supply all along.

    For what its worth (and I know I'll get a lot of raised eyebrows for this), I keep the sides of the tower cases removed. Again, the cases are identical, so chances are the heating properties are also nearly identical. For whatever reason, I couldn't rig up fans to cool the case enough with the sides on. With the sides off, I left a digital thermometer in the cases of each, and near the video card itself, the temperature didn't rise above 75°F/24°C in either case. I have doubts that its an overheating issue, but of course it isn't something to rule out.

    From an outside observer, what do you think the problem is?

    Thanks
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/697597

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice