3D Device problems? What do I do?

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Baltimore1993

Thread Starter
Joined
Dec 27, 2010
Messages
2
I have a DeLL Inspiron B130 Laptop that is either 2005 or 2006 model and was wondering how I can fix an apparent graphic problem when I click 'Play Game' for Civilization IV. I have played it before on the PC but had to uninstall it and reinstalled it later. Here is the error message that appears. How can I fix this/ can I?

INITIALIZE RENDERER FAILED. CHECK Directx Installation latest Graphics Drivers and Graphics Settings.
Parameters:
-width=1024
-height=768
-flags=0xc
-hwnd= 0x1boo5a
adaptrid=0
deviceid=3

Error: Creation failed: Invalid 3D device type.
 
Joined
Dec 6, 2003
Messages
1,936
Reinstall or upgrade the video card drivers *from the manufacturer's website*. Do not use reference drivers from Nvidia or AMD on a laptop. The video drivers are specifically written for the video card AND the motherboard.

Next, reinstall the latest DirectX drivers from Microsoft. Download the latest from http://www.microsoft.com/downloads/...roductID=9C954C37-1ED1-4846-8A7D-85FC422D1388. Download the runtime. This program will check your drivers and download what you need to bring the drivers up to date.
 

Baltimore1993

Thread Starter
Joined
Dec 27, 2010
Messages
2
Thank you so much for clarifying this and I have updated the latest DirectX and have found my real problem is not having the proper videocard, I am not even sure if I have one. So I am on http://www.driverskit.com/Video_Card.html and am looking at different videocard downloads. I am not sure if this is a safe site (such a noob) and was wondering if this is the right way to go?
The next problem is I am not sure which one I should go for and if you don't don't know, how could I find out? Again, the only problem I think is I do not have the proper videocard.
Thank you so much, this is awesome!
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top