A cascade of errors in vista

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

twistedvince

Thread Starter
Joined
Nov 8, 2005
Messages
120
I have no idea what do do about this.In a period of three weeks errors in my vista machine are running wild.It started with Vista suddenly not recognizing my flash drives.That now includes my two external hard drives as well.It shows them as being there,but at every boot up is searches for divers for them.The driver search always ends with"windows encountered a problem installing the driver software for your device,windows found driver software for your device but encountered an error while attempting to install it.".I do not have access to my scanner,mp3,camera.....nothing.I'm also encountering way to many "Windows explorer has encountered a problem and needs to close" errors lately.M
The latest error was yesterday when I got"Microsoft register server has stopped working"....twice.Add to this other things,such as erratic keyboard errors(space bar stops working)and the fact that my "run as administrator"option has disappeared from my context menu,has me quite concerned.I've tried a few fixes I thought might apply but to no avail.My temperatures are all well within range.I ran sfc /scannow and found no problems.
Comp-HP M8020N
Ram-4gb

Does anybody have any ideas??
Should I uninstall Vista SP1?Or would that make matters worse?
Any help would be appreciated.
Thank You

PS I just tried to use system restore for the USB issue and found that it's not functioning either....what the hell is going on here???:(
 
Joined
May 12, 2007
Messages
2,487
For USB devices, it may be simplets to remove the usb drivers altogether. If you unplu all USB devices, then go to device manager, you should be able to right click on all usb ports and remove them. Once that is done restart, and it should detect and reinstall them. ten try plugging in USB devices one at a time , with a restart betwen each. Hopefully a clean usb install will cure it. :)
 

twistedvince

Thread Starter
Joined
Nov 8, 2005
Messages
120
Actually.....everything usb is now showing up under "other devices....yet usb.The point is ....with vista,I never NEEDED drivers for most of my usb stuff......or so i thought.At each reboot the system looks for all these drivers.
All this seems to have happened AFTER my vista Sp1 upgrade.Maybe I should un-install it.
Any suggestions?
 

twistedvince

Thread Starter
Joined
Nov 8, 2005
Messages
120
For USB devices, it may be simplets to remove the usb drivers altogether. If you unplu all USB devices, then go to device manager, you should be able to right click on all usb ports and remove them. Once that is done restart, and it should detect and reinstall them. ten try plugging in USB devices one at a time , with a restart betwen each. Hopefully a clean usb install will cure it. :)
BTW..I tried doing what you said...and vista recognized NOTHING at all.It didn't reinstall the usb hubs.....so i tried system restore and found out thats not working either.....:mad:
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top