1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

A disk read error occurred

Discussion in 'Windows XP' started by drfter, Sep 20, 2003.

Thread Status:
Not open for further replies.
  1. drfter

    drfter Thread Starter

    Joined:
    Sep 20, 2003
    Messages:
    3
    (Not sure if this is more fitting for the hardware forum, but it seems to sort of center around Windows....)

    I have a dualboot Gateway machine (out of warranty) with Red Hat Linux 9 on the master hard disk (Maxtor 80 GB), which runs GRUB as my bootloader, and Windows XP Pro SP1 on the slave (Western Digital 175 GB). A few weeks ago I tried starting up my computer, and got the error "A disk read error occurred" after I selected Windows. After going through this a few times, I played around with the inside of my computer. No loose cables, jumpers seemed okay. I disconnected the Maxtor hard disk (everything except physically taking it out of the computer) and set up the WD one as single to no avail. I've tried using the Recovery Console, where I can confirm that my files (or at least the one the damn thing lets me see) are alright (at least I can list them, move around directories, and I opened a text file), but fixboot didn't do a thing for me. Chkdisk didn't see any problems right away, but after running it with /p it reported "one or more errors." I ran it with /r and it fixed "one or more errors," which it later affirmed were all fixed. I also used the full media test on the WD lifeguard disk with "no errors."

    Anyway, I can use Linux just fine. I already had NTFS read support, but it can't read anything off /mnt/winxp (where I mounted the other hard disk, and where I've been able to read it before). The terminal lets me cd to it, but says "ls: reading directory .: Not a directory" when I try to list its contents.

    The most recent thing I believe I installed was TI Connect (XP version) for my TI-83+ calculator, but that's been around for a few days and I've restarted since then. I had gone into Hibernate mode when I last turned the computer off, which I had also used successfully prior to this problem. Since then I used the Recovery Console to delete the hibernate file that Windows looks for when it starts up (so it knows whether or not to return from hibernate). As for Red Hat being the cause, I've had my computer set up as dualboot since early July, and this is the first real problem I've had since the regular installation bumps.

    So, I think I've covered most of what happened. Virtually all of the files I've ever created are on the XP drive, and given that I know (or at least have reason to believe) that they're intact, reformatting simply isn't an option (well, it is, but I'm already aware of that alternative and don't need to be reminded of it). Reinstalling doesn't work, because if I try to do so with the Linux drive as Master, it wants to put bootup files on that drive. If I put the XP drive as Master/single, then setup stops right after it "inspects your computer's hardware configuration" or whatever it does. I am relatively computer literate, but I don't have that much experience with system errors, so try to bear with me. I've also done plenty of searching and came up with little.

    Any and all help is appreciated. Thanks.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/166179

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice