About my digital camera and USB?

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Muffy7

Thread Starter
Joined
Apr 13, 2005
Messages
306
for some reason when i plug my camera into the usb port and i select "run on pc" on my camera, nothing happens on my PC when the last time i performed this precedure, everything worked perfectly?

help/?

k thanks
 
Joined
Jun 13, 2005
Messages
1,023
Uninstall and reinstall the USB ports through Device manager. Just right click on each entry, click uninstall, and once all are gone, right click anywhere in the window and 'scan for new hardware'. Windows will then reinstall the usb ports.

If that doesn't work, come back.

Scorp.
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,429
Unplug ALL USB devices.
Open Device Manager.
View, Show Hidden Devices.
Uninstall all devices under USB Controllers.
Uninstall all devices under Storage Volumes. Say no to any reboot prompts until you are finished. Also, if a Storage Volume doesn't uninstall, ignore it and move to the next one.
If you have a yellow ? with unknown devices, uninstall all of the entries there as well.

When this is done, reboot TWICE.

Reconnect the USB devices and see if they're recognized properly.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Top