1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Access Denied

Discussion in 'Networking' started by ronr, Jan 27, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. ronr

    ronr Thread Starter

    Joined:
    Mar 16, 2004
    Messages:
    16
    I have a small network with a Windows 98SE computer, 2 windows XP Home computers, and a Windows XP Professional computer. All of them show up on the network and three of them share files just fine. It's the Pro machine that won't share. The error msg is: \\computernameis not accessible. You might not have permission to use this network resource. Access is denied." This machine can open files from the other computers. So it is not connectivity.

    I configured it to share files and printers, I have named the shared folders, I have turned off every mention of firewall I could find, and I turned on Simple Sharing.

    What am I missing?
     
  2. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    78,246
    First Name:
    Terry
    Can you ping the XP Pro by IP address? By computer name?
     
  3. N E Key

    N E Key

    Joined:
    Aug 5, 2004
    Messages:
    132
    Is the file system on the XP Pro, NTFS or FAT32. You can go from an NTFS system to FAT32, but not the reverse.
     
  4. jmwills

    jmwills

    Joined:
    Sep 28, 2005
    Messages:
    3,477
    You have a third party firewall (yes I saw where you said you tunred off every mention of a firewall) but that is the classic error for a third party firewall.

    Turn OFF Simple File Sharing
     
  5. ronr

    ronr Thread Starter

    Joined:
    Mar 16, 2004
    Messages:
    16
    Yes, I can PING the PRO computer
     
  6. ronr

    ronr Thread Starter

    Joined:
    Mar 16, 2004
    Messages:
    16
    The XP computers are NTFS, the 98 is FAT32. However, the 98 can open files on the other 2 XP Home machines.
     
  7. jmwills

    jmwills

    Joined:
    Sep 28, 2005
    Messages:
    3,477
    Turn Off Simple File Sharing
    Make Sure the File/Folder is Actually Marked As Shared
    Make Sure YOu have Enabled permissions not only on the Share but the Folders as well by using the Everyone permission
     
  8. ronr

    ronr Thread Starter

    Joined:
    Mar 16, 2004
    Messages:
    16

    Turned off Simple File Sharing

    I have (I think) enabled sharing...even on the root of C: at this point...and under the tab for permissions, selected Everyone and Full Access. I'm not sure about what you mean by "not only on the Share but the Folders as well...
     
  9. jmwills

    jmwills

    Joined:
    Sep 28, 2005
    Messages:
    3,477
    You not only have top have permissions on the share but the folder or files within the share.

    Say that I want to Share a Folder named Temp on the C Drive and within that Folder is a Folder named Whatever. You have to give Permissions to the Share (the Temp Folder) and also to the Whatever Folder.

    Note that on the XP Home machines, the only folder you can Share in the Share Folder in Documents & Settings All users.
     
  10. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    78,246
    First Name:
    Terry
    Sometimes a disabled or not-quite-completely-uninstalled firewall can permit ping by IP address (and by name) and still block file sharing. But usually your situation means registry corruption. If messing around with advanced file sharing doesn't get you working, I can post the fixes we know about and you can try your luck.
     
  11. ronr

    ronr Thread Starter

    Joined:
    Mar 16, 2004
    Messages:
    16
    I have pillor-to-post on shares...permissions...the last thing I tried was through Control Panel>Admin tools>Local Security where I disabled "Limit local account use of blank passwords to console login only (which was to allow network access w/o a password).

    I haven't been into the Registry because this problem is exactly the same as a small network I am working on for another person...he has a Pro computer that shares and one that will not...so I have been thinking it is something about setting up the Pro machine on my network and on his...but not a registry thing. But tell me the fixes - I'm ready to try just about anything!
     
  12. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    78,246
    First Name:
    Terry
    Here are the two I know about. The first is for XP Home and for XP Pro using SFS.

    Possible Fix for corruption “Access Denied” Problem:

    Using notepad create a file named FIXANON.REG with the following contents:

    ------------------- cut after this line -------------------
    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
    "restrictanonymous"=dword:00000000
    ------------------- cut before this line -----------------

    Double click on the file and say Yes to the merge into registry question.

    Restart and see if this helps with the access issue.
    -----------------------------------------------------------------------------------

    Another: (XP Pro w/SFS, and probably Win2k Pro)

    I have found a solution to a problem that I see many people have been experiencing. That is when you try to access a computer on the network you get the following error:

    \\_________ is not accessible. You might not have permission to access this network resource.

    Contact your administrator and blah blah blah.

    I found three methods on this forum and others which seemed to have worked for many people, but did not for me. Those were:

    1. Enabling NetBIOs
    2. Changing the "restrictanonymous" registry entry to 0. (mine was already 0)
    3. Changing the IRPStackSize

    None of these three worked for me. After talking with a Microsoft rep on the phone I seem to have solved this problem. I hope this can help the others out there.

    Here is what I did:

    Start Menu --> Control Panel
    Double-Click Administrative Tools
    Double-Click Local Security Policy
    Click "User Rights Assignment" on the left panel
    Look for the top entry on the right panel listed "Access this computer from the Network"
    Right-Click --> Properties
    Click "Add User or Group"
    Click "Advanced" --> Find Now
    Select and press ok to add a User or Group. Add all of the following:

    Administrator
    Guest
    Everyone
    NETWORK

    Press OK two more times and you're done. I didn't even have to restart before it was working.

    -Jarrad
     
  13. ronr

    ronr Thread Starter

    Joined:
    Mar 16, 2004
    Messages:
    16
    Thank you to all who responded. I learned more from each of you. As it turned out, for the home network the break was when I created a log in name for each of what would be the clients to the XP Pro w/o needing a password. For the other network, the break was when I finally did find 3rd party firewall software running.

    Thanks again for all the help
     
  14. jmwills

    jmwills

    Joined:
    Sep 28, 2005
    Messages:
    3,477
    That's good to hear.
     
  15. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/538935

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice