accessing vista shared printer from mac

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

me34543

Thread Starter
Joined
Dec 5, 2011
Messages
2
Hello,

I am sharing a canon mf4350d printer installed on a vista home premium edition computer. I am trying to access it on an imac using osx 10.6.8. Below are the steps I have taken so far:

1. On vista machine in the control panel I have checked off the "share this printer" box in the printers properties.

2. In the registry of the Vista machine I have changed the value of lmcompatibilitylevel from 3 to 1 and then rebooted.

3. On the Imac in system preferences I opened "Print and Fax" and clicked "+" to add a printer.

4. I clicked on the "IP" button and set the "Protocol" to "Line Printer Daemon - LPD"; in the "Address" field I entered the IP address of the vista machine; In the "Print Using" I set to "Generic PCL Laser Printer".

When I try and print it can't connect to the printer and it does not print. Any help in solving this would be appreciated

Thanks!
 

TerryNet

Moderator
Joined
Mar 23, 2005
Messages
80,317
First Name
Terry
On the Vista did you turn on printer sharing? Did you configure any non-Windows firewall for the desired access?

Vista refuses to file share unless at least one user account is password protected. Don't know if that is needed for printer sharing.
 

me34543

Thread Starter
Joined
Dec 5, 2011
Messages
2
Thank you for the response.

1. Printer Sharing is turned on in Vista

2. Non-windows firewall is set so that it should allow for printer sharing

3. One or more user accounts is password protected - the mac user account is password protected and I am also currently able to access files in a folder shared on the vista machine through the mac. The problem is strictly in sharing the vista connected printer.
 

TerryNet

Moderator
Joined
Mar 23, 2005
Messages
80,317
First Name
Terry
As I know nothing about MACs, I cannot help. Sorry. Sounds like the Vista side is OK.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top