1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Acer Aspire 5100 Connection issues

Discussion in 'Networking' started by superpousom, Mar 21, 2009.

Thread Status:
Not open for further replies.
Advertisement
  1. superpousom

    superpousom Thread Starter

    Joined:
    Nov 23, 2004
    Messages:
    33
    My laptop, and Acer Aspire 5100 has always had a lousy internet connection, and I've just dealt with it until yesterday.

    First off, some recent background- Two days ago I upgraded the RAM in my laptop from 1gig to 4gigs, and I had an internet connection, albeit a lousy one. It wasn't until yesterday morning that after we had the Verizon FiOS network set up that my computer started having worse issues.

    It would repeatedly connect and dsiconnect at very short intervals. It would allow me to click maybe three links and last a total of 20 seconds before it shut off and restarted again. Every other computer in the house had (and has) a perfectly good wireless connection.

    After messing around with it for a bit, I ended up shoving all of my important data onto a USB flash drive like Noah's Ark and just flattened the whole system. After I reinstalled Vista, the problem was still there.

    I browsed the internet for a bit (in those short bursts in which I could) and became fairly certain that the problem was an out of date network adapter driver. And so I downloaded and installed one for the Atheros AR5007EG (My network adapter). After I installed it, my laptop didn't event recognize the network card anymore. It won't even show up on Device Manager. It asked that I "install driver software for my ethernet controller".

    And that's where I am right now. I'm using another computer to type this post with the one with the bum internet connection right next to me. I'm running Vista Premium x32, and I can dig up any other information you need to help me out. Anyway, thanks for helping. :)

    One more thing- I've contacted Acer technical support and found out that my laptop is out of warranty, and is no longer supported. Their website isn't a help at all.

    edit: Even when directly connected to the router via cable, the problem still persisted (before when the adapter was recognized)
     
  2. superpousom

    superpousom Thread Starter

    Joined:
    Nov 23, 2004
    Messages:
    33
    Installed the driver off of Acer's site. Back to having the original problem from my first post.
     
  3. superpousom

    superpousom Thread Starter

    Joined:
    Nov 23, 2004
    Messages:
    33
    It seems like my drivers for it are up to date. I could be wrong, but is there something else it could be?
     
  4. TerryNet

    TerryNet Terry Moderator

    Joined:
    Mar 23, 2005
    Messages:
    69,509
    Download from Acer's web site your Vista chipset and networking drivers. Install the chipset, then the networking, then check Device Manager to see if you need any other drivers.
     
  5. superpousom

    superpousom Thread Starter

    Joined:
    Nov 23, 2004
    Messages:
    33
  6. TerryNet

    TerryNet Terry Moderator

    Joined:
    Mar 23, 2005
    Messages:
    69,509
    Product line 'Notebook.' Then select 'Aspire 5100' and Search. Why that gets 57 results and only one is for Aspire 5100 I do not have a clue. :(
     
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/811285