1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Acer Aspire notebook detects network but, won't connect

Discussion in 'Networking' started by fstredz, Nov 10, 2009.

Thread Status:
Not open for further replies.
  1. fstredz

    fstredz Thread Starter

    Nov 10, 2009
    My girlfriends Acer Aspire notebook and will not connect to her wireless internet anymore. she has a Linksys WRT54GS2 Wireless-G Broadband Router. i connected to her internet with my compaq presario QC60-419WM notrbook and now her notebook will not connect.
  2. JohnWill

    JohnWill Retired Moderator

    Oct 19, 2002
    I can't imagine that connecting a different computer to the router has anything to do with this issue.

    Please supply the following info, exact make and models of the equipment please.

    Name of your ISP (Internet Service Provider).
    Make and exact model of the broadband modem.
    Make and exact model and hardware version of the router (if a separate unit).
    Make and exact model and hardware version of any other network equipment, like a repeater, a booster, hi-gain antenna, etc.
    Model numbers can usually be obtained from the label on the device.
    Connection type, wired or wireless.
    If wireless, encryption used, (none, WEP, WPA, or WPA2)
    Version and patch level of Windows on all affected machines, i.e. XP (Home or Pro), SP1-SP2-SP3, Vista (Home, Business, Ultimate), etc.
    The Internet Browser in use, IE, Firefox, Opera, etc.

    Please give an exact description of your problem symptoms, including the exact text of any error messages.

    • If you're using a wireless connection, have you tried a direct connection with a cable to see if that changes the symptoms?
    • For wireless issues, have you disabled all encryption on the router to see if you can connect that way?
    • For wireless laptops, have you made SURE the wireless switch is on?
    • For wired connection issues, have you booted in Safe Mode with Networking to see if that changes the symptoms?
    • Have you connected directly to the broadband modem to see if this is a router or modem/ISP issue?
    • If there are other computers on the same network, are they experiencing the same issue, or do they function normally?

    On any affected computer, I'd also like to see this:

    Hold the Windows key and press R, then type CMD (COMMAND for W98/WME) to open a command prompt:

    Type the following commands on separate lines, following each one with the Enter key:


    PING yahoo.com

    NBTSTAT -n


    Right click in the command window and choose Select All, then hit Enter.
    Paste the results in a message here.

    If you are on a machine with no network connection, use a floppy, USB disk, or a CD-RW disk to transfer a text file with the information to allow pasting it here.


    Nov 11, 2009
    Have a similar problem.
    ACER aspire 7720G laptop model ick70 sn 30410983315 Vista home premium , IE,with intel PRO/Wireless 3945abg inside. Does not connect anymore to linkysy wireless G broadband router model WRT54G. Have three other pc's (2 desktops and one laptop ) continue to work without problems and hooking up to the wifi like before. (Laptop uses different brand networkadaptor card) Think problem probably started after removing trojan virus with Malwarebytes and or updating vista. I've browsed several threads and learned the 3945 has a history of problems and do not know if it is OK or not. ipconfig shows the intel3945 as disconnected. and IP address, subnetmask and std gateway are Tried ipconfig/release and .../renew does not work as the adapter is listed as disconnected. Although DHCP and DNS server setting is on "automatic" somehow it is not working. System tries to hook up(WiFI led lights up) but unsuccessfully. Tried router shutdown/restart without result though.
    Connecting to the internet with cable is NO problem.
    Any suggestions ?
  4. JohnWill

    JohnWill Retired Moderator

    Oct 19, 2002
    IP addresses of all zeros are normally caused by one of the following.


    1. DHCP Service not running.
    2. Duplicate IP address on the network.
    3. Bad NIC card drivers.
    4. Defective NIC hardware.


    1. Check Control Panel, Administrative Tools, Services. The DHCP Client service should be Started and its Startup Type should be Automatic.
    2. Turn off ALL of the computers and other network connected devices, restart (power cycle) the router, then restart all the computers and other network devices.
    3. Check for upgraded drivers and/or reload the Network drivers.
    4. Replace the Network Interface Card.
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/876288