1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Acer laptop suddenly gives black screen, doesn't start anymore

Discussion in 'Hardware' started by maniakbogu, Oct 26, 2019.

Thread Status:
Not open for further replies.
  1. maniakbogu

    maniakbogu Thread Starter

    Joined:
    Oct 26, 2019
    Messages:
    1
    Hello, this is my first time here so sorry for any possible mistakes.
    LAPTOP: Acer Aspire 4810T (yes old lappy)
    Windows: 7 32bit
    What happened: I finished reinstalling windows 7 on the laptop and was finishing installing some programs (office 2013) when the laptop's display went black and the laptop became unresponsive. The bottom of the laptop was indeed very hot. After that I tried to let it cool down abit and start it up, only to have the power led light up and the fan start up and stop after 2 seconds. Anything else is unresponsive. No display nothing. This state is same even now.
    What I tried: Hard reseting (unplugging battery and the ac adapter, pressing the power button for 1 minute then plug the ad back and try to start up), reseating the Ram sticks, trying to swap around 1 ram stick at a time to both places, try a different ram stick from another laptop, getting the HDD out and then back in, removing the cmos battery and then connecting it back in, trying another ac adapter (same 19V voltage on output and same jack, it comes from a working Acer laptop), tried connecting a monitor to the vga connector.
    I literally disassembled it and reassembled it many times.
    Nothing works. Same thing, power led goes on, fan starts spiking for 2 seconds then stops, and no display not even a dim light, the second monitor doesn't even detect it just says 'check cable'
    Worth mentioning: On the original AC adapter connected, the laptop doesn't start if the cmos battery is not connected, but with the secondary ac adapter the power led lights up even without the cmos battery connected. It actually lights up and the fan starts spining for 2 seconds as soon as the AC adapter is connected, without needing to press the button.
    I have no way in testing if the original AC adapter delivers all the 19V.
    Sorry for the long wall of text but I wanted to be very specific and have enough info of everything I tried.
    I am with this laptop for a long number of days already and I really don't know what else to try/do. Any help would be amazingly appreciated. Please help.
     
  2. SpywareDr

    SpywareDr

    Joined:
    Mar 30, 2014
    Messages:
    3,428
    Sounds like the CPU may be overheating and the laptop is shutting down -- as they are designed to do -- so that it doesn't start a fire.

    Also, it the CPU did get to hot and started melting internally, you'll need a replacement for it and no telling what else that might have been damaged.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1234823

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice