1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Acer-Windows 8-Atheros Driver issues!!

Discussion in 'Networking' started by Sammy2111, Sep 27, 2013.

Thread Status:
Not open for further replies.
Advertisement
  1. Sammy2111

    Sammy2111 Thread Starter

    Joined:
    Dec 28, 2012
    Messages:
    146
    So i finally realised after hours and hours of research,Acer actually had the problem of not giving out correctly configured drivers and the such,in nearly all acer laptops,there is a atheros integrated chip of some kind,and All of us are suffer from the same problem!,thanks to these,they make our connection go limited after a few minutes,no idea why,but its definetly on Acers side,does anybody have a fix for this until they release the drivers properly, they said v10.0.0.234 would fix it,but it didnt so i went back to v.10.0.0.217 for now (this still disconnects also). any help would be appreciated :)
    My laptop is a Acer Aspire V3-531,
    Card is Qualcomm Atheros AR5BWB222

    Guess ill need some links to backup my point,so here you go :) -
    -http://community.acer.com/t5/Notebooks-Netbooks/Acer-wifi-limited-connectivity-issue/td-p/3405
    -http://www.neowin.net/forum/topic/1099385-qualcomm-atheros-ar5bwb222-wifi-adapter-no-longer-works-in-rtm-did-in-rp/page-2
    -http://www.ppartyka.com/2012/12/tutorial-windows-8-laptop-keeps.html
    -http://www.forumswindows8.com/network-sharing/wpa2-psk-problem-cannot-connect-network-8938.htm
    -http://community.acer.com/t5/Notebooks-Netbooks/Aspire-V3-571-wireless-disconnects/m-p/10279#U10279
    -http://community.acer.com/t5/Notebooks-Netbooks/Does-updated-WiFi-driver-10-0-0-217-fix-anybody-s-intermittent/m-p/19863#M4606
     
  2. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    76,846
    First Name:
    Terry
  3. Sammy2111

    Sammy2111 Thread Starter

    Joined:
    Dec 28, 2012
    Messages:
    146

    ill try the driver now :p , ill post back feedback after a day or two,but if it happens any sooner,ill post back
     
  4. Sammy2111

    Sammy2111 Thread Starter

    Joined:
    Dec 28, 2012
    Messages:
    146
    No luck,The driver went from Connected to limited in about 10 minutes, this was the driver installed from atheros.cz version 10.0.0.251.
     
  5. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    76,846
    First Name:
    Terry
    Well, 10 is more than "a few." :)

    You'll probably have to just keeping checking the Acer site.

    What encryption are you using? Have you tried with encryption disabled?

    If you are using Channel Bandwidth of 40 MHz have you tried 20 MHz?
     
  6. Sammy2111

    Sammy2111 Thread Starter

    Joined:
    Dec 28, 2012
    Messages:
    146
    Haha,it varies most of the time,just wants to turn off when it wants to XD.
    Im using WPA2-ASK Encryption,i havent tried it without the encryption so i guess its worth giving a shot?
    How do you change the channel bandwidth?
     
  7. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    76,846
    First Name:
    Terry
    If (note the IF) there is a bandwidth setting in the router's wireless section you'll see how to change it. :)

    If it works OK with no encryption then try WPA-PSK (not WPA2).
     
  8. Sammy2111

    Sammy2111 Thread Starter

    Joined:
    Dec 28, 2012
    Messages:
    146
    it does not work at all with WPA-PSK [TKIP] so i guess that is out of the question :(
    And im guessing you are on about the 2.4 and 5ghz frequencies? it does disconnect on both of them,randomly also.

    Shame im not the only one with this issue,its happening to loads of people who have a Atheros card with windows 8,just wish Acer would test the drivers throughly before releasing them XD :)
     
  9. Sammy2111

    Sammy2111 Thread Starter

    Joined:
    Dec 28, 2012
    Messages:
    146
    Bump.

    Still not working,gonna try the driver again from Atheros.cz's Unoffical site.But im guessing this will work to no Avail
     
  10. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1109369

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice