active all sata ports

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

silencerahel

Thread Starter
Joined
Mar 8, 2010
Messages
7
hello this is my first post on these forums, i've used them alot before and allways found the answers i was looking for without ever posting a question until this happend to me I have a m3n78-em asus motherboard with 5 sata slots inside and 1 external sata port on the rear next to serial ports well today i got my fourth internal hard drive and it would not read i thought maybe it was a dead hard drive but no it was the actual slot that was not reading out of the 5 slots that are on the mb 3 are red and 2 are black those 2 black ones cannot be used at all i checked out the motherboard manual and found the sata mode selection i was thinking of changing that to ahci or raid but i dont want to screw anything up right now its set for sata mode which was default and i just want to be able to have all my 4 hard drives up and running without having to do anything major and taking any of the 4 out is not an option thank you for your time if i dont respond its probably because im asleep since im way to tired and my post really sucks because of it
 

silencerahel

Thread Starter
Joined
Mar 8, 2010
Messages
7
Thanks for the reply, yes I have tried to enable them in bios but sata slots 1-3 are the only ones that appear. 4 which is the external one 5 and 6 which are the other two near 1-3 do not show up in bios at all. The only way I know for a fact that its my sata slots is that I unplugged one of my good hard drives that allready read on slot 3 and put my new drive in slot 3 and that drive in slot 4 and Bam, It worked. Apparently if I switch to AHCI mode or RAID mode I can use all of my sata ports. It's really the only option I've found but I've all ready installed my OS and am in a dual boot, there is really no way I can uninstall this I would lose to much. It might sound like I have the answer to my own question but it's really unclear to me because some people said you are able to get AHCI mode on with your operating system all ready installed with a certain registry from Intel and a driver install, but I think that only goes for certain MB's.
 

silencerahel

Thread Starter
Joined
Mar 8, 2010
Messages
7
I converted my BIOS to ACHI mode and now my sata ports are all detected and I can use all my hard drives. I guess I didn't need to come here at all. I don't know exactly what ACHI mode does in the long run besides the extra commands and a few other things and my dual boot is going to have a cow if I switch back to it but I will have to deal with that when it comes. The reason I was confused in the beginning is that everyone keeps saying ACHI is not for the average user and will probably cause more problems than it will help. That was a major throw off for me but it seems that switching after editing the registries worked, not from the intel website or whatever because I don't have a intel chipset. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci changing the value to 0 and then booting and changing in BIOS to ACHI did the trick well thanks anyway
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top