Ad-hoc network loses internet connection after standby.

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

markraymond

Thread Starter
Joined
Jun 8, 2007
Messages
73
Hi, I've set up a wireless ad-hoc network between two laptops. The host laptop has an ethernet connection to the net through a router. The second laptop connects to the net through the host laptop over the wireless ad-hoc network. It all works perfectly until either of the laptops goes into standby.

When both laptops connect up again the host laptop connects to the net no problem but the non-host laptop can't connect to the internet through the host. Both laptops are actually connected because I can access the non-hosts laptops shared folder and vice-versa.

The only way to fix this is to restart both laptops and then it works perfectly again.

Both laptops are running XP Pro SP3.

Hope my explanations not too confusing! Anyone any ideas, please!:)
 

markraymond

Thread Starter
Joined
Jun 8, 2007
Messages
73
Here's some extra information, I've done the nbtstat -n, ipconfig /all thing on both laptops when everything is ok then again when the internet connection *****-up.

Host laptop when everthythings ok

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Mark>nbtstat -n

Marks wireless net:
Node IpAddress: [192.168.0.1] Scope Id: []

NetBIOS Local Name Table

Name Type Status
---------------------------------------------
MARK <00> UNIQUE Registered
DOMA <00> GROUP Registered
MARK <20> UNIQUE Registered
DOMA <1E> GROUP Registered

Marks Wired net:
Node IpAddress: [10.0.0.2] Scope Id: []

NetBIOS Local Name Table

Name Type Status
---------------------------------------------
MARK <00> UNIQUE Registered
DOMA <00> GROUP Registered
DOMA <1E> GROUP Registered

C:\Documents and Settings\Mark>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : MARK
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : Yes
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Marks wireless net:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : 11a/b/g Wireless LAN Mini PCI Adapte
r
Physical Address. . . . . . . . . : 00-05-4E-48-64-F4
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.0.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

Ethernet adapter Marks Wired net:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Mobile Connecti
on
Physical Address. . . . . . . . . : 00-0D-60-75-A4-D1
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 10.0.0.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 10.0.0.138
DHCP Server . . . . . . . . . . . : 10.0.0.138
DNS Servers . . . . . . . . . . . : 10.0.0.138
Lease Obtained. . . . . . . . . . : 16 September 2008 17:36:52
Lease Expires . . . . . . . . . . : 26 September 2008 17:36:52

C:\Documents and Settings\Mark>
Non host laptop - everything ok

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Petra>nbtstat -n

Wireless Network Connection:
Node IpAddress: [192.168.0.118] Scope Id: []

NetBIOS Local Name Table

Name Type Status
---------------------------------------------
PETRUNKA <00> UNIQUE Registered
PETRUNKA <20> UNIQUE Registered
DOMA <00> GROUP Registered
DOMA <1E> GROUP Registered
DOMA <1D> UNIQUE Registered
..__MSBROWSE__.<01> GROUP Registered

Local Area Connection:
Node IpAddress: [0.0.0.0] Scope Id: []

No names in cache

C:\Documents and Settings\Petra>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : petrunka
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : mshome.net

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . : mshome.net
Description . . . . . . . . . . . : Broadcom 802.11b/g WLAN
Physical Address. . . . . . . . . : 00-21-00-29-19-CC
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.0.118
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 192.168.0.1
Lease Obtained. . . . . . . . . . : 16 September 2008 17:38:39
Lease Expires . . . . . . . . . . : 23 September 2008 17:38:39

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connecti
on
Physical Address. . . . . . . . . : 00-1E-EC-75-00-B2

C:\Documents and Settings\Petra>

Host after the connection *****-ups.

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Mark>nbtstat -n

Marks wireless net:
Node IpAddress: [192.168.0.1] Scope Id: []

NetBIOS Local Name Table

Name Type Status
---------------------------------------------
MARK <00> UNIQUE Registered
DOMA <00> GROUP Registered
MARK <20> UNIQUE Registered
DOMA <1E> GROUP Registered
DOMA <1D> UNIQUE Registered
..__MSBROWSE__.<01> GROUP Registered

Marks Wired net:
Node IpAddress: [10.0.0.2] Scope Id: []

NetBIOS Local Name Table

Name Type Status
---------------------------------------------
MARK <00> UNIQUE Registered
DOMA <00> GROUP Registered
DOMA <1E> GROUP Registered

C:\Documents and Settings\Mark>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : MARK
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : Yes
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Marks wireless net:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : 11a/b/g Wireless LAN Mini PCI Adapte
r
Physical Address. . . . . . . . . : 00-05-4E-48-64-F4
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.0.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

Ethernet adapter Marks Wired net:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Mobile Connecti
on
Physical Address. . . . . . . . . : 00-0D-60-75-A4-D1
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 10.0.0.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 10.0.0.138
DHCP Server . . . . . . . . . . . : 10.0.0.138
DNS Servers . . . . . . . . . . . : 10.0.0.138
Lease Obtained. . . . . . . . . . : 16 September 2008 17:36:52
Lease Expires . . . . . . . . . . : 26 September 2008 17:36:52

C:\Documents and Settings\Mark>

Non-host after connection *****-up.

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Petra>nbtstat -n

Wireless Network Connection:
Node IpAddress: [192.168.0.118] Scope Id: []

NetBIOS Local Name Table

Name Type Status
---------------------------------------------
PETRUNKA <00> UNIQUE Registered
PETRUNKA <20> UNIQUE Registered
DOMA <00> GROUP Registered
DOMA <1E> GROUP Registered

Local Area Connection:
Node IpAddress: [0.0.0.0] Scope Id: []

No names in cache

C:\Documents and Settings\Petra>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : petrunka
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : mshome.net

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . : mshome.net
Description . . . . . . . . . . . : Broadcom 802.11b/g WLAN
Physical Address. . . . . . . . . : 00-21-00-29-19-CC
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.0.118
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 192.168.0.1
Lease Obtained. . . . . . . . . . : 16 September 2008 17:38:39
Lease Expires . . . . . . . . . . : 23 September 2008 17:38:39

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connecti
on
Physical Address. . . . . . . . . : 00-1E-EC-75-00-B2

C:\Documents and Settings\Petra>
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,531
Try checking the adapter characteristics in Device Manager for each machine and disabling any power saving options. This may or may not help, but it's one thing to try. Obviously, I'd also visit the manufacturer's website and download/install the latest wireless driver.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top