1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Add/remove Windows (xp) Components

Discussion in 'Windows XP' started by synergy46, Oct 20, 2003.

Thread Status:
Not open for further replies.
Advertisement
  1. synergy46

    synergy46 Thread Starter

    Joined:
    Oct 17, 2003
    Messages:
    15
    When I open ADD/REMOVE PROGRAMS and then click on the ADD/REMOVE WINDOWS COMPONENTS I get two error messages and nothing shows. Any ideas anyone?

    Messages:
    1) Setup was unable to load the master information file.
    2) The application could not be initialized.


    I am running Windows XP Pro with all the updates and patches installed.
     
  2. JenniferLore

    JenniferLore Banned

    Joined:
    Jul 7, 2003
    Messages:
    262
    The file sysoc.inf might be missing or corrupt. It is located in
    c:\windows\inf folder.
    You'll have to extract this file from either the Service Pack 1 i386 folder or The windows xp installation cd. After you have a copy, put it in the inf folder.

    That should solve your problem.
     
  3. synergy46

    synergy46 Thread Starter

    Joined:
    Oct 17, 2003
    Messages:
    15
    Found the sysoc.inf file but it is not corrupted.

    [Version]
    Signature = "$Windows NT$"
    DriverVer=07/01/2001,5.1.2600.1106

    [Components]
    NtComponents=ntoc.dll,NtOcSetupProc,,4
    (about 25 lines below this)

    [Global]
    WindowTitle=%WindowTitle%
    WindowTitle.StandAlone="*"

    SInce the file is NOT corrupted, and if I copy the file from my XP disk, won't I loose all the component settings etc... that are in my existing file?
     
  4. synergy46

    synergy46 Thread Starter

    Joined:
    Oct 17, 2003
    Messages:
    15
    update: copied the file into my system/inf directory and tried to ADD/REMOVE components. Got the message that the file WBEMOC.INF could not be found. grrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr
     
  5. synergy46

    synergy46 Thread Starter

    Joined:
    Oct 17, 2003
    Messages:
    15
    Just searched my drive for WBEMOC.INF and SEARCH found nothing!!??? The specific err message is:
    SETUP WAS UNABLE TO FIND WBEMOC.INF. CONTACT YOUR SYSTEM ADMINISTRATOR. ERROR [email protected] 2011777033
     
  6. JenniferLore

    JenniferLore Banned

    Joined:
    Jul 7, 2003
    Messages:
    262
    You have the same problem I had with a computer at work. Almost all of the essential inf files were missing. I fixed it by restoring the files from the install CD. These files are always the same unless you knowingly change them. So if you restore the file you won't have to worry about changing what was once there.

    This file is on the i386 folder on the Windows cd. It is WBEMOC.IN_
    copy it to the inf folder then change the extension from IN_ to INF.

    Do this for every file that is missing. Sorry I don't have a quicker solution: I know this is tedious.
     
  7. synergy46

    synergy46 Thread Starter

    Joined:
    Oct 17, 2003
    Messages:
    15
    Thanks. I have just moved so when I find my XP disk I will follow your advice.
     
  8. synergy46

    synergy46 Thread Starter

    Joined:
    Oct 17, 2003
    Messages:
    15
    Just got my XP Pro disk. FOllowed the procedure above but the WBEMOC.IN_ file appears to be BINARY and is not recognized by the ADD/REMOVE PROGRAMS -- Add Remove Windows Components program. When I looked inside the IN_ file it looked like ...
    MSCF ¡ ,   G  Ï +Is wbemoc.inf Õ¥ìRÏ[€€òl 3D3 oeXí ƒ8˜`]Y‰‘ɼ[9 Cbã±MlÙÖ»sÝêöëî\¶ý÷(ÿ C D# VfźçR–@Ø¿€Ïb„RŸ¶¯íên½tÙ¶®Ž…L2ÚÚeŠ4 ܆¬¦9£¸•‘¶†06¤Œ•±äJŒï’ÂE ¿/ûïØþ @ H ˆˆa™|wkÕ#à 8ÏÏûÏ`”lÛ56u3›Ÿò²u

    Œæ¡„ HhZD=”GQC@8M*1x7(d¹ãþaPð8øçÁ‚%DåÈ4—ž
    sbð¥íF~¾[email protected]êEBÕé* ,
    

    Of course when I try and access ADD/ REMOVE PROGRAMS it just says "SETUP WAS UNABLE TO OPEN FILE WBEMOC.INF....etc"
    Any ideas???
     
  9. JenniferLore

    JenniferLore Banned

    Joined:
    Jul 7, 2003
    Messages:
    262
    Did you change the extension from IN_ to INF?
     
  10. synergy46

    synergy46 Thread Starter

    Joined:
    Oct 17, 2003
    Messages:
    15
    Yes, I renamed the file with INF as a file extension. Still doesn't work. Shouldn't it be in 'text file' instead of binary file format?

    Ron
     
  11. JenniferLore

    JenniferLore Banned

    Joined:
    Jul 7, 2003
    Messages:
    262
    It should be text: -- I've attached the file. Use this one on your computer. Since "techguy" attachments have to have certain extension Change the .txt extension to .inf when you download it.
     

    Attached Files:

  12. synergy46

    synergy46 Thread Starter

    Joined:
    Oct 17, 2003
    Messages:
    15
    Thanks for the file. But, now I get the message that "setup was unable to open the info file "FXSOCM.INF". Will this EVER stop :)
     
  13. interruptor

    interruptor

    Joined:
    Jul 9, 2008
    Messages:
    1
    rename in_ files to ZIP and extract! :)
     
  14. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/173324

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice