1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved Advanced TCP/IP Settings, DNS tab, Can't click OK

Discussion in 'Networking' started by wsmacl, Nov 19, 2015.

Thread Status:
Not open for further replies.
  1. wsmacl

    wsmacl Thread Starter

    Joined:
    Jan 2, 2007
    Messages:
    12
    I am using a notebook that came with Windows 7 and upgraded to Windows 10. I noticed this problem 6 months ago (before upgrading to Windows 10), but it was not causing a problem, so I ignored it until now.
    I am trying to switch to other DNS name servers. I set up the new DNS server addresses in the TCP/IPv4 properties, but they were not working. Checking the advances setting, under the DNS tab, I noticed that there is a long set of addresses (from IPconfig it seems to be 8) on the first line in DNS server addresses box. (See image. Note - the bottom two addresses had come over from what I had set up in the TCP/IPv4 properties).
    ScreenHunter_01 Nov. 19 16.32.jpg
    I can not remove this series of addresses. The remove button is not greyed out, but nothing happens when I click it.
    Same with editing it (nothing happens when I click Edit).
    I can add addresses, edit added addresses and remove added addresses.
    I can also move the top line down, but when I click "OK" nothing happens. To close the dialog box I must click Cancel.
    If I open the advanced dialog box and do not click the DNS tab, I can close the dialog box by clicking OK, but once I open the DNS tab, clicking OK will not longer work. Even if I go back to the IP Settings tab, clicking OK will switch it to the DNS tab, but will not close it.


    Anyone have an idea how I can reset this? Or remove this top line of addresses?
    Thanks.
     
    Last edited: Nov 19, 2015
  2. wsmacl

    wsmacl Thread Starter

    Joined:
    Jan 2, 2007
    Messages:
    12
    OK, I figured this out myself. But in case someone else has the problem, here is the solution I figured out.
    The problem was the GUI interface was locking up or not responding correctly, so I figured I had to find a manual way to change (or erase) the DNS servers that were blocking things up. I figured there was probably a way via the command prompt, and in fact, that is how we solved things.
    I started an admin session of the command prompt (Win+X - Command prompt (admin))
    Then I ran the netsh utility (typed netsh).
    From the netsh command prompt I typed:
    "interface ip set dnsservers "Wireless Network Connection" source=dhcp"
    That did the trick. I immediately checked the settings and sure enough the long string of DNS servers was gone.
    BTW, "Wireless Network Connection" was the connection I was having trouble with. This told netsh to switch the DNS server names for that connection back to selecting the DNSservers automatically.
    I could also replaced "source=dhcp" with "static 54.93.27.100" (Note this is not a valid DNS server) to have it set to that DNS Server. Or I can now go in and change it manually.
    Problem solved!
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1160708

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice