1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Alienware M14x Second HDD Hang?

Discussion in 'Hardware' started by nosammai, Jun 23, 2012.

Thread Status:
Not open for further replies.
Advertisement
  1. nosammai

    nosammai Thread Starter

    Joined:
    Jun 23, 2012
    Messages:
    1
    I just installed a second hard drive in place of the optical drive in my Alienware M14x R1. I put an SSD into the main drive bay, and installed a caddy with the original HDD (Western Digital Scorpio Black 500gb) into the optical drive. I did a fresh install of windows onto the SSD, and planned to use the HDD for data and games. It seemed to be working fine (windows recognized it, and I could transfer data to and from it) but all of a sudden, the hard drive started randomly 'hanging' when reading from the drive. For example, when copying data from the drive, it will stop on a single file, and sit there for a while, then continue for a while and repeat.

    I opened up the Resource manager and pulled up the disk tab to watch the graphs while the hangs occurred. When the hangs happen, the blue line (Highest Active Time) for the HDD goes up to 100% and stays there, occasionally spiking down to zero but then back up again. Meanwhile the shaded green line goes all the way down (I think this means there is no IO activity happening).

    The weird part is that all of the hangs are exactly one minute in length, every single time. I'm not sure if it's relevant, but that is also the amount of time it takes for 1 cycle of the resource manager graph. During that time, I can't read or write from the HDD, but the SSD is perfectly fine. If I'm playing music from the HDD, it stops, then continues after the hang stops.

    I checked the System Event Viewer for errors, and sure enough I'm getting Event ID 11 ATAPI error "The driver detected a controller error on \Device\Ide\IdePort1." Usually they occur in groups of 5 or more in the event viewer. I read up on the error, however most of the information on it was fairly dated and about old PATA or SCSI drives. A lot of people seemed to say it might be a cabling issue, so I'm having dell ship me a new ribbon cable for the optical drive under warranty.

    I'm relatively sure the problem isn't the HDD itself because it was working perfectly fine as my main system hard drive a couple days ago. Whenever I run benchmarks or tests on the HDD it comes out fine, with the results it should deliver. The hangs only seem to occur when copying large amounts of data, or during loading screens of games. I don't think it's a problem in Windows because I tried running Linux off of the drive and it was running horrendously slow as well. I did read that the SATA port for the Optical drive is only SATA 1.5 Gb/s, but I don't think that should be causing it, unless somehow the WD drive needs to be forced to run in 1.5 Gb/s mode instead of 3.0 Gb/s (In HWiNFO64, the drive shows up as 3.0Gb/s).

    At this point I think it's either the ribbon cable that connects the caddy to the mainboard, the caddy, or the sata controller for the optical drive on the mainboard.

    Specs:
    Alienware M14x R1
    Intel Core i7-2630QM @ 2.0 Ghz (2.9 Turbo)
    8GB DDR3 1600 Mhz RAM
    Intel HD 3000 Integrated Graphics
    3GB nVidia Geforce 555M With Optimus
    IntelĀ® Wireless-N WiFi Link 1000 a/g/n 1x2

    The HDD Controller is set to AHCI mode in the BIOS(Rev A08, Unlocked).

    Any help or suggestions are welcomed and greatly appreciated! I'd be happy to provide any additional information you need.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1058290