1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

All browsers except Firefox fail to connect

Discussion in 'Web & Email' started by heavyarmoire, May 4, 2010.

Thread Status:
Not open for further replies.
Advertisement
  1. heavyarmoire

    heavyarmoire Thread Starter

    Joined:
    May 4, 2010
    Messages:
    2
    Hey, this is my first post here, and after much perusing on the internet and this site, none of what I read seems to be my problem. I've tried a few things to correct this, based on the other problems I've read, but they didn't shed any light into it.

    So my internet does not work with any browser except Firefox. I have the newest Opera 10, Beta Opera 10.5 or w/e, Firefox 3.5.9 and Google Chrome. As well as IE.
    None of them connect to the internet except Firefox.

    I don't exactly know when they stopped working, since I haven't touched Opera(s) or IE in months, and just installed google chrome (which is when I noticed the problem).
    I have Avast!, Ad Aware SE and PC Tools Firewall Plus. I haven't had any other firewalls installed.
    I've tried disabling them, and it didn't work.
    What did work was restarting in safe mode with networking, and when I was in that mode I ran ccleaner to try and fix any registry errors that might've come up, but it didn't work. I also ran a virus check and a spyware check, I had some crap but I cleared it out.
    I don't think it's any addons, since it would have to be something that comes with Google Chrome that also works in Opera and IE.

    The exact thing Google Chrome says is this:
    Error 102 (net::ERR_CONNECTION_REFUSED): Unknown error.

    Any help would be greatly appreciated.
     
  2. Bernardo

    Bernardo

    Joined:
    Jan 8, 2006
    Messages:
    4,221
  3. heavyarmoire

    heavyarmoire Thread Starter

    Joined:
    May 4, 2010
    Messages:
    2
    That worked for google chrome, but what was the source of the problem? Like how/why did it happen, and to all the browsers?
     
  4. Bernardo

    Bernardo

    Joined:
    Jan 8, 2006
    Messages:
    4,221
    I can't say. Perhaps if you google the error message that the others give you, it will find a solution as well :) That's all I did :D
     
  5. retiredPhil

    retiredPhil

    Joined:
    May 2, 2010
    Messages:
    3
    I had a similar problem and Microsoft solved it by having me reset IE. Followed the following instructions.

    Method 1: Reset Internet Explorer (IE) & register files
    =================
    Please note: this step will set all the IE settings to default state. Some personal information, such as homepage and cookies will also be affected, but your Favorites will not be reset. I suggest we first backup our personal files before we proceed.

    1. Click Start, please type “inetcpl.cpl” (without quotation marks) in the Start Search bar and press Enter to open the Internet options window.
    2. Switch to the Advanced tab.
    3. Click the "Reset Internet Explorer Settings" button.
    4. Click Reset to confirm the operation.
    5. Click Close when the resetting process has finished.
    6. Uncheck the "Enable third-party browser extensions" option in the Settings box.
    7. Click Apply, click OK.
    8. Check the result.
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/921095

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice