1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

all (high spec) games lag after 30 minutes or so

Discussion in 'Games' started by stefandunn, Nov 10, 2009.

Thread Status:
Not open for further replies.
Advertisement
  1. stefandunn

    stefandunn Thread Starter

    Joined:
    Nov 10, 2009
    Messages:
    5
    Hi,

    This is my first post, and hopefully the problem can be solved. Usually I don't need to post on forums like these, but for this, I cannot solve the problem.

    Okay, so when I play a high-end game (such as Crysis, Race Driver: Grid, Dead Space) I get good FPS of 40+ for the first 30 minutes or so, however the game then goes into a loop of lagging for a few seconds then resuming to the 40+ FPS for around a minute then starts lagging again for a few seconds and so on until I quit the game. Once I do quit the game, and re-open it, it works fine again for another 30 minutes and then does the same thing again.
    Things I've already tried are:

    1. Update official drivers from their official websites (nVidia, Intel, Samsung etc).
    2. Closed down any consuming applications such as antivirus, msn, steam etc.
    3. Placed more fans into my case to prevent overheating (but I don't think this is the issue as I can restart a game it works fine again for 30 minutes)

    Can anyone give me any suggestions.

    Stefan,

    P.s. I am running windows 7 however the issue has occurred in Windows XP, Vista and 7. My specifications can be seen on my profile.

    Thank you
     
  2. peck1234

    peck1234

    Joined:
    Aug 27, 2008
    Messages:
    1,257
    most likely its your underpowered Pentiem D which is causeing the lag...

    Crysis And Dead Space are Quad/Dual Core Optimized...

    Also just to get an idea what your temps are please download hwmonitor and post a screenie of your temps after about 10 minutes of gaming....

    Link Below...
     
  3. stefandunn

    stefandunn Thread Starter

    Joined:
    Nov 10, 2009
    Messages:
    5
    My GPU reaches temperatures of 65 when running Crysis, and 68 when running Grid. (this is when I ran it before, new GPU driver has no temperature monitor feature).

    The problem is, if it were my CPU then wouldn't it lag all the time, not for short periods of time and 30 minutes in?!
     
  4. peck1234

    peck1234

    Joined:
    Aug 27, 2008
    Messages:
    1,257
    Your CPU could be reaching a threshold (TJMAX) after 30 minutes in...

    Please run hwmonitor in the background of gaming and post a screenie of your temps after you recieve your lag..... This will rule out both cpu and gpu overheating....
     
  5. stefandunn

    stefandunn Thread Starter

    Joined:
    Nov 10, 2009
    Messages:
    5
    I've attached it, however, not sure what the screen shows.
     

    Attached Files:

  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/876074

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice