Always crashing/ or huge lag

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Fred2592

Thread Starter
Joined
Oct 29, 2011
Messages
1
Hi, i'm a total noob with computers and im absolutely clueless of what's going on...

my pc keeps lagging or crashing when i play games :confused:

my specs:
Acer Aspire AX3300
OS: Windows 7 Home Premium 64-bit
CPU: AMD Athlon II X2 240 dual core processor
Memory: 3 GB DDR3
HDD: 320GB
ODD: DVD Supermulti drive
VGA: NVIDIA 9200 Integrated Geforce

Now, from what i've heard this aint really a 'gaming-computer' but i play games like GTA San Andreas on lowest graphics and it gives me a huge lag after like 2 minutes of playing, and the other game i play is Age Of Empires Rise Of Rome and it makes my computer crash after a couple of minutes.. very frustrating. BTW they're both original, NOT downloaded.

What could be causing this?

Cheers, Fred
 
Joined
Nov 4, 2011
Messages
51
Your using an integrated card. As Prunejuice has stated, its definitely not the most powerful card out there. If you are to purchase a new card, however, I would wait untill the end of this month, as Black Friday tends to carry some pretty intense savings all around.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top