1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Associate .rtf files with Wordpad problem

Discussion in 'Earlier Versions of Windows' started by amthmi, Feb 1, 2003.

Thread Status:
Not open for further replies.
Advertisement
  1. amthmi

    amthmi Thread Starter

    Joined:
    Mar 23, 2002
    Messages:
    519
    I've run into a strange problem on a friends pc.
    First let me say he had the MTX virus on his pc.
    I've removed the virus via the fixmtx.exe tool. It found 157 infected
    files and fixed 154 of those files. The 3 that it didn't, I assumed
    were wsock32.dll, explorer.exe, and rundll.exe which were
    corrupted due to the virus. I extracted those files from the 98se cab files.
    Reference:
    http://www.pchell.com/virus/mtx.shtml
    http://service1.symantec.com/sarc/sarc.nsf/html/pf/w95.mtx.html
    Bottom line...I followed the instructions to the letter and
    everything is fine now.
    The problem: (which I don't believe is related to the mtx virus)
    FYI items:
    Windows98se and Office2000 are installed.

    I was attempting to associate .rtf files with WordPad which
    is (or should be) very easy to do.
    Open explorer..shift right-click, open with and scroll to Wordpad
    and check the box to always use bla bla bla...
    This is where things get a little strange...
    If you check the box to "always use bla.." it opens the rtf file in Word.
    If you don't check the box it opens in Wordpad as it should.
    I tried it a few times just to make sure I wasn't hallucinating.

    I went into folder options / file types and saw Rich Text Format listed.
    It was associated with Word. I did edit it to be associated with Wordpad.
    I thought I did it correctly by browsing to Wordpad's executable file.
    It says (if you look at file types again) that it's set to open with Wordpad.

    Oh let me add something about what happens when the "always use bla.."
    is checked....Word opens but it doesn't open the file.

    This isn't a huge problem just annoying (it's not my pc) and I'd like
    to try and straighten it out. I'm going back over to his place tomorrow
    so if anyone has an idea what may be causing this feel free to advise me.

    Thanks..
     
  2. Balzac

    Balzac Guest

    I had this problem and never figured it out. I recently formatted and did a clean install of my Win98se and it's working again.

    You can look through your registry for rtffile and change the program associated with .rtf file extension. It's not the proper fix for the situation but maybe a workaround.

    For example I set windows to always open the .rtf extension with word pad through the "open with" applet
    This is what my rtffile key looks like:


    [HKEY_CLASSES_ROOT\rtffile]
    @="Rich Text Document"

    [HKEY_CLASSES_ROOT\rtffile\DefaultIcon]
    @="C:\\PROGRA~1\\ACCESS~1\\WORDPAD.EXE,1"

    [HKEY_CLASSES_ROOT\rtffile\shell]

    [HKEY_CLASSES_ROOT\rtffile\shell\open]
    @=""

    [HKEY_CLASSES_ROOT\rtffile\shell\open\command]
    @="C:\\PROGRA~1\\ACCESS~1\\WORDPAD.EXE \"%1\""

    [HKEY_CLASSES_ROOT\rtffile\shell\print]

    [HKEY_CLASSES_ROOT\rtffile\shell\print\command]
    @="C:\\Progra~1\\Access~1\\WORDPAD.EXE /p \"%1\""

    [HKEY_CLASSES_ROOT\rtffile\shell\printto]

    [HKEY_CLASSES_ROOT\rtffile\shell\printto\command]
    @="C:\\Progra~1\\Access~1\\WORDPAD.EXE /pt \"%1\" \"%2\" \"%3\" \"%4\" "

    [HKEY_CLASSES_ROOT\rtffile\CLSID]
    @="{73FDDC80-AEA9-101A-98A7-00AA00374959}"
     
  3. pyritechips

    pyritechips Gone but Never Forgotten

    Joined:
    Jun 2, 2002
    Messages:
    26,907
    First Name:
    Jim
    Hello!

    If you have win98 go to start > run... and enter winfile

    Once there use the folder list on the left to navigate to a folder so that you can see a file of the type you want to assiciate in the right window.

    Highlight the file in the right window and at the top click file > associate.

    In the Associate box, make sure the file type is indicated. The middle line is the current associated program. At the bottom, browse to the program you want the file type to be opened with.

    Click ok and that should work


    :)
     
  4. Balzac

    Balzac Guest

    pyritechips.......That's hot. Thanks for the heads up. Never knew about the winfile function.

    That's a hell of alot easier. :D
     
  5. amthmi

    amthmi Thread Starter

    Joined:
    Mar 23, 2002
    Messages:
    519
    Funny , for the longest time, while everyone had migrated to explorer , I was
    a diehard filemanager user. I know exactly what you're talking about
    with regards to file associations with winfile. I'll bring a copy of winfile.exe
    with me tomorrow and give it a try.
    Thanks, I don't think I would have thought of that.
    I'll let you know the outcome.
    * I still find it bizarre the issue with the "always use this program"
    checkbox behavior*
     
  6. amthmi

    amthmi Thread Starter

    Joined:
    Mar 23, 2002
    Messages:
    519
    Oh does anyone know if winfile.exe is included in win98se ?
     
  7. pyritechips

    pyritechips Gone but Never Forgotten

    Joined:
    Jun 2, 2002
    Messages:
    26,907
    First Name:
    Jim
    Yes amthmi

    I have 98se and that's what I just used. If it shows up as missing try using SFC to restore it.
     
  8. amthmi

    amthmi Thread Starter

    Joined:
    Mar 23, 2002
    Messages:
    519
    Many thanks pyritechips, and you too balzac for you input.
    I just brought up winfile on my pc.
    Now that I use explorer exclusively it makes file manager look strange.
     
  9. pyritechips

    pyritechips Gone but Never Forgotten

    Joined:
    Jun 2, 2002
    Messages:
    26,907
    First Name:
    Jim
    Glad to have helped! :)
     
  10. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/116492

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice