1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Asterisk overlapping problem!

Discussion in 'Linux and Unix' started by joenational, Jan 18, 2007.

Thread Status:
Not open for further replies.
  1. joenational

    joenational Thread Starter

    Joined:
    Dec 21, 2005
    Messages:
    51
    Hey guys, just wondering if any of you guys have bumped into this problem before on Asterisk 1.09 and updated zaptel and now when a phone call is placed into the office an overlapping occurs and no call can actually be placed or picked up. Have any of you guys had this issue. We need this to be up by the morning and are in quite a bind right now. Any help or guidance would be appreciated.

    FYI it is 10:42pm EST time.

    Thanks,
     
  2. gotrootdude

    gotrootdude

    Joined:
    Feb 19, 2003
    Messages:
    8,812
    Ugh, I've learned the hard way to never update any package on a working Ast system.

    Look at the bottom of your /etc/asterisk/zapata.conf

    Check your signalling and echo cancellation.

    signalling=fxs_ks ; X100P
    echocancel=yes ; You can set this to 32, 64, or 128, tweak to your needs.
    echocancelwhenbridged=yes
    echotraining=400 ; Asterisk trains to the beginning of the call, number is in milliseconds
    callerid=asreceived
    group=1
    context=default ; Points to the default context of your extensions.conf
    channel => 1

    Sample zapata.conf's for different setups: http://www.voiptalk.org/products/basic_digiumconfig.html

    I'd suggest backing up your configs, and reinstalling the system from scratch if needed. You might even putty in, nano the configs, and cut and paste.

    Next time use linux personal backup appliance to image your Asterisk box before attempting updates.
     
  3. joenational

    joenational Thread Starter

    Joined:
    Dec 21, 2005
    Messages:
    51
    Thank you very much, We actually wound up reinstalling it ontop of the exisiting, also after doing some seaching found that certain files (cant think of them right now) were not taking to the update. So got rid of those files and once everything was reinstalled they updated. However the next day the server just went to junk and wasn't taking any calls at all. You couldn't call out or receive anything. So I then had to hard boot the server in order for it work again. Has been up since but there was no cut and dry resoolution to this.

    Thanks again,
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/536466

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice