1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

asus C300 error: Chrome OS is missing or damaged

Discussion in 'Other Mobile Devices' started by Johnsbobber79, Jul 16, 2017.

Advertisement
  1. Johnsbobber79

    Johnsbobber79 Thread Starter

    Joined:
    Jul 16, 2017
    Messages:
    1
    my asus chromebook is froze up. error showing is Chrome OS is missing or damaged, Please insert a recovery USB stick or SD card. I have tried the following, let it charge for 6 hours. tried plugging chromebook to power outlet to see if it would turn on. unpluged from wall outlet, pressed and held down power key for 60 seconds. this all began with a black screen. I got it to power up by pressing alt/power keys @ the same time. Held refresh and power keys no go. Took it apart and disconnected the battery (twice) again no go. There is no restart or reset. Had this same error show up on another laptop and was able to powerup and shut down 20 times and then the windows page came up, cannot do this on the chromebook because I have to press power and alt keys to get off the black screen so the same process will not work. This one has got me by the neck so any input,suggestions or advice would be greatly appreciated. Really don't want to do a hard reset and lose all the files and data that is on it. thanks for your time in reading this and I hope to hear from you soon.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Short URL to this thread: https://techguy.org/1193168