1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Asus maximus formula

Discussion in 'Hardware' started by satara1d, Mar 31, 2008.

Thread Status:
Not open for further replies.
  1. satara1d

    satara1d Thread Starter

    Joined:
    Mar 29, 2008
    Messages:
    1
    Hi everyone i am starting to build a new system with a maximus formula mobo. Having installed cpu , ddr2 etc ,deciding i was ready for a first time power test i swithed on psu which is a corsair hx620 , the led s on the board are lit , press on , cpu and psu fan turn for 2 secs and thats it. led s remain lit Does anyone have any advice pleaze!!
     
  2. brite750

    brite750

    Joined:
    Mar 16, 2002
    Messages:
    13,404
    make sure all power plugs are plugged into the MB, make sure cpu hsf is plugged into correct header on mb, you may have to have the gfx installed as well
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/698869

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice