Asus ROG laptop won't boot into windows after adding RAM

VanzyHQ

Thread Starter
Joined
May 29, 2020
Messages
2
So basically I was going to upgrade my ram from 8gb to 16gb. So I bought an extra 8gb 2666mhz stick of crucial. My laptop (Asus rog strix hero edition 2018) has a specific part that you can open at the back of the laptop to add another ram stick and a part with the SSD and the HDD. When I installed the extra RAM. The laptop booted into the BIOS. So I thought that was normal because I added new ram or something. And the ram was actually detected as my ram in the bios said 16gb (a little more but don't remember the exact number). So I pressed F10 which made it save and exit the bios. So it started up again, but just like earlier. It got into the BIOS. So I checked the information in my BIOS. And apparently my SSD is not being recognized. As it says I have no NVME drives installed or something similar. Which is weird because I didn't even touch the SSD. Now I downloaded a windows installation tool on a USB flash drive. And when entering Command Prompt. My HDD had become my main drive. The C: Drive. While all the time before that, my SSD was my C: Drive. Is there anyone who can help me with this problem?

My laptop specs:
I7-7700HQ
GTX 1060 3gb
8gb ram ddr4
128gb toshiba SSD (always used without any issues as it was the ssd that came with the laptop.
1tb seagate hdd (also came with the laptop).
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top