Asus t100ta won't charge

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Bskrazyy

Thread Starter
Joined
Nov 1, 2016
Messages
2
I looked all over the Internet and tried all suggested things. My asus t100ta won't turn on it only blinks a red light once when I plug it in to charge or when pressing the power button. I tried multiple chargers same thing happens. I can't figure out if it's the battery, the micro USB charging port or bad motherboard. But the micro USB port looks well intact without damage. The red light comes on even when the batter is unhooked with the charger plugged into it.
 

lochlomonder

Colin
Trusted Advisor
Spam Fighter
Joined
Jul 24, 2015
Messages
3,754
Try holding in the Power and Home buttons together for 30 seconds, and then release.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top