1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

ATAPI Devices takes 15 sec. search to be found.

Discussion in 'Windows XP' started by stars1234, Nov 16, 2003.

Thread Status:
Not open for further replies.
Advertisement
  1. stars1234

    stars1234 Thread Starter

    Joined:
    Aug 6, 2003
    Messages:
    53
    System Windows 2000 Pro. 80 gig Maxtor HDD, 120 gig WD HDD, CD-ROM, CD-RW.

    Whenever I change the place of an already recognized drive on the IDE cable, be it the Primary or Secondary Channel, Windows 2000 has to search for that drive.

    It finally finds it, but takes a full 15 seconds to go through the "searching for IDE devices."

    In checking the BIOS (selecting "pause" as soon as the system comes on), I see that it has recognized the drive in its new position, immediately. But once into POST, it's like it has no clue where the drives are.

    I've tried pulling the power, disconnecting the IDE cables to the drives on each channel, but that didn't help.

    I tried reloading the cmos with fail safe defaults and
    doing as above, but still no luck.

    I tried the above, disconnected all AC power (pulled the plug), waited, re-powered, and booted, but the same thing.

    I've tried uninstall the drives by the Control Panel. Then letting Windows find and install them. Still no good.

    Although the BIOS standard setting or optimal or my tweaked,
    finds the changed drive immediately (using "auto"), there
    is something happening when the system goes into full
    POST, that it can no longer find the drives.

    I know that W2k & XP retain the location of the drives as they were originally found when the system started. But the "Searching for IDE devices" appears before the "starting windows" screen.

    I even tried clearing the CMOS and left it there for a couple of hours.

    Do, I need to reflash it?

    I'm at a loss as to how to get the IDE device that has been changed to a new position on the cable, to be "re-found," without the system doing a long search for it. This happens whether the drive is a HDD or CD.

    It first happened when I added a new HD to the system. As long as I had the new HD set as slave (even though it was the new master and in the master position on the cable), there was no "searching for IDE," but as soon as I returned it to its new "Master" jumper--the 15 seconds to find the IDE Devices happened again.--although inside the BIOS it showed it immediately as being recognized as the new master drive.

    I did something (wish I could remember exactly what)--I thought it was pull the power, clear the CMOS, and then install the drives one by one, and the problem disappeared.

    Now that's part of it, the HDDs is working, but when I plugged back in my CD drives--without changing their position the same 15 second wait occurs.

    I have only the CD burner as master on the Secondary Channel, everything is recognized immediately. But when I add back in my CD-ROM as slave on the Secondary Channel, although recognized in the BIOS, POST takes 15 seconds to find the IDE devices.

    It looks like Microsoft KB 328624 talks about this but give no
    solution, workaround, or anything other than stating that the problem has been observed.

    I'd like to know what it is, why it's happening, and how do I fix it?

    I wonder how I fixed it when I had the same problem with two HDDs on the same channel (Primary)?

    If someone could tell me why it's acting this way and how to fix it, I'm ready to learn.

    It's probably something simple, but something I'm just overlooking it?

    Bob

    p.s. I'm still of the old school of keeping fast devices with fast, etc. So my HDDs are all on the primary channel and my optical drives on the secondary channel. Does this matter any more? Would I do just as well, or better to put on each channel, the HDD as master, with a CD slave? Or still keep fast with fast and slow with slow?

    But 1st, how do I get the system to not loose track of the drives and have to do a 15 second search for them, each time it starts?
     
  2. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    You might certainly want to look for an updated BIOS.

    Recently, I had a problem similar to yours with a new drive, but it was more like 5 minutes for detection and sometimes it failed altogether.

    Changing the settings in BIOS from Auto to User and manually entering the drive's parameters speeded things up since autodetection and configuration were no longer needed, but updating the BIOS finally got it back to its old boot speed.
     
  3. stars1234

    stars1234 Thread Starter

    Joined:
    Aug 6, 2003
    Messages:
    53
    Thanks for the suggestion.

    I do have the latest BIOS.

    I can reflash it--hate to do those things though--if the power should fail--well--you know what I mean.

    I wonder, should I leave everything setup as is and flash the BIOS, or disconnect all IDE devices, flash the BIOS and then put them back on like one by one.

    There seems like there should be another solution to this than flashing the BIOS every time you add a new device?
     
  4. stars1234

    stars1234 Thread Starter

    Joined:
    Aug 6, 2003
    Messages:
    53
    I've tried everything I can think of, but no luck. My BIOS is at least two years newer than any of the IDE devices.

    Maybe it have something to do with W2K writting some code into the BIOS?

    I read someplace that there is a reserved space in the BIOS that W2k & XP uses to keep track of the devices.

    When I first installed W2K, I had only a CD-ROM on the Sec. IDE chnl, set as Master. Later, I added a CD-RW, switching places on the cable and the jumper settings. No problem. Except the CD-ROM retained it's drive letter.

    Then I tried to add a new HDD to the system.

    I cloned the old HDD to the new one with GHOST. I used Part. Mgc. to set the new drive as active. On reboot, instead, it wipped C off HDD0 and trashed the new HDD.

    On rebooting, I got an "unable to verify DMI pool error." It took many attempts to get past that.

    I used "C:'s" backup to get it going again.

    I had to do a low level format of the new HDD before it would be recognized at all--now it's seen as an unformatted drive, and with all the right paramaters.

    But, just as now, once getting that old drive back up--I found it took 15 seconds for "Searching for IDE devices" to find it. (BIOS is set to AUTO & works right.)

    I disconnected everything, pulled the power, drivers off from the CP. Finally, flashed the BIOS, cleared the CMOS--no effect.

    I pulled all my hair out. Took several tranquilizers, rejumperd the the CMOS to "clear." and went to bed.

    The next day I tried to start the system but it wouldn't do anything. Totally dead.

    After two hours of trying, including swapping power supplies, I reallized I had not reset the CMOS jumper from "clear."

    Did that, the system came to life and AMAZINGLY, the HDDs were found instantly in the BIOS and during the POST. --I haven't a clue why.

    I added the opticals: CD-RW, Sec. Mstr.--OK.
    CD-ROM, Sec. Slv., POST went back to 15 seconds to find all the IDE devices.

    Pulling out the Sec. Slv., all IDE devices are found immediately.

    Reinstall it and remove the CD-RW, Sec. Mst. all are found. But together, it's the 15 second wait to detect the IDE devices.

    I'm an MCSE-NT4, I guess we are mostly tech people here--what is happening?

    MS KB only said this had been reported, gave no indications why or any fix. I had never seen a KB that only said "this has been reported" and nothing else.

    Do I dare try putting the errant optical as a slave on another channel? I'm a bit afraid to since I've run into so many "verifying DMI pool data" crashes.

    But I've glued my hair back in, so that's ok, and I have the bottle of tranqilizers ready to go if you or anyone have more suggestions.

    Bob
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/179950

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice