1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

ATI Mobility Radeon X1400, Driver and DVD copy protection problem,

Discussion in 'Hardware' started by firestormer, Nov 10, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. firestormer

    firestormer Thread Starter

    Joined:
    Sep 16, 2005
    Messages:
    1,254
    Right this problems been bugging me for a while:

    I can only play some dvd's on the old version of my ATI Mobility Radeon X1400 driver and only play some on the new.

    Which means when i come to play a dvd i have a 50% chance of having to roll back or update the driver depending upon the last dvd i played.

    Here is the error message:
    http://www.microsoft.com/windows/wi...&id=C00D1163&contextid=61&originalid=C00D1163

    Here are some spec details:
    Dell Inspiron 6400 (its a laptop)
    Windows Vista Home Premium
    ATI Mobility Radeon X1400
    Philips DVD + RW SDVD8820

    Please help me before i slit my throat

    fsuk
     
  2. warlord

    warlord

    Joined:
    Oct 11, 2005
    Messages:
    109
    the problem is you are using windows media player to play the movie. use the player that came with the drive. at least this is what happened to me when i had that problem. part of the reason i still use wmp6
     
  3. Bigfella

    Bigfella

    Joined:
    Nov 10, 2007
    Messages:
    40
    either that or cyberlink power dvd it will have its own codecs
     
  4. Bigfella

    Bigfella

    Joined:
    Nov 10, 2007
    Messages:
    40
    If you cant view the dvds then it may be your region or drive type.
     
  5. firestormer

    firestormer Thread Starter

    Joined:
    Sep 16, 2005
    Messages:
    1,254
    It dosn't matter what software i use, and its not a problem with regions. It is a problem between the driver for my DVD drive and the driver for my graphics card, i only used the media player error message because it gives the most information whereas others just despair.

    "Windows Media Player cannot play this DVD because there is a problem with digital copy protection between your DVD drive, decoder, and video card."

    Other programs just say, "DVD: Copy-protect fail"
    If i then update the graphics card the DVD will play fine, but if insert a different DVD there is a an equal chance the error message will appear again and i will have to roll back the driver.

    I suspect it may be older DVDs that will only play on the old driver and newer DVD's that will play only on the new version.
     
  6. firestormer

    firestormer Thread Starter

    Joined:
    Sep 16, 2005
    Messages:
    1,254
    ARRR, ok it turns out its not the driver version.

    After a shutdown, it is just neccesary to change the driver, one way or the other in order to play any DVD

    ARRRRR!!!!
     
  7. IceKold0

    IceKold0

    Joined:
    Jul 17, 2008
    Messages:
    1
    OK, Right, a proper solution as I've just had the exact some problem!

    MPC complaining "DVD: Copy-Proect Fail" and Windows Media Player's error message of copy-protect failed or similar.

    I have installed both the famous K-Lite Codec Pack AND another fairly widely used pack, CCCP (Community Compiled Codec Pack).

    The solution I found is to make sure that "libmpeg2" and "FFDShow" are both installed (K-Lite and CCCP both install these)

    1) Open the FFDShow configuration and click the very first item in the menu to the left (labelled "Codecs")

    2) Look down the first column (labelled "Format") for "MPEG2".

    3) IF the box to the right of "MPEG2" says "disabled" then this is why you cannot play DVDs using your applications.

    4) Click the word "disabled" which will show a drop down menu with three options -> "disabled", "libavcodec" and "libmpeg2".

    5) ensure that "libmpeg2" is selected.

    6) with the line "MPEG2 | libmpeg2" line highlighted look at the bottom of the FFDShow configuration window and you will see a tick box labelled "DVD decoding". If this is unticked, tick it.

    7) Click apply.

    8) Click "OK" to close the FFDShow configuration

    9) Start up your MPC, Windows Media Player or VLC and (hopefully) you should now be able to watch DVDs again!


    If anyone wants screen shots of the options then don't hesitate to get in touch.
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/650210

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice