1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Attempt to access internet causes MSAFD.dll error

Discussion in 'Web & Email' started by Opie C., Oct 10, 2003.

Thread Status:
Not open for further replies.
  1. Opie C.

    Opie C. Thread Starter

    Joined:
    Oct 8, 2003
    Messages:
    2
    I recently scanned my PC for spyware using Ad-aware, and it found over 60 items (most of them in the registry), which I proceeded to place under quarantine. Then, when I tried to turn off my computer, it froze, and when I restarted it, I was unable to connect to the internet. The computer works fine until any program tries to access the internet, at which time I get an error message saying that the program caused a problem with a file named MSAFD.dll, and it gives me the options of closing it or debugging it (nothing happens when I click on the latter). Here are the details of the message I get when I try to use Internet Explorer:

    EXPLORER caused an invalid page fault in
    module MSAFD.DLL at 017f:7c113580.
    Registers:
    EAX=00000001 CS=017f EIP=7c113580 EFLGS=00010213
    EBX=00000006 SS=0187 ESP=00aefc2c EBP=00aefc58
    ECX=00000000 DS=0187 ESI=00000000 FS=30f7
    EDX=819126a4 ES=0187 EDI=006c0e80 GS=0000
    Bytes at CS:EIP:
    8b 7e 24 8d 45 10 50 6a 00 6a 01 6a 01 e8 c9 0c
    Stack dump:
    006c0e80 006c19cc 00000001 78869f1f 78869f42 bff7b9b6 81942114 006c1650
    788628e9 006c0e8c 006c19e0 00aefc90 7a44145a 00000002 00000001 00000006

    A similar message appears for all other programs that try to access the internet. After choosing to close the program, the following message appears:

    Runtime error: -2147417848 (80010108) / Automation error

    I have tried replacing the MSAFD.dll file in Windows\System with a file of the same name and size that I found in another folder, but it didn't solve the problem. I have also checked my registry for errors, but none were found. I then tried to restore the registry with a backup made before running Ad-aware (using scanreg from DOS), but, for some reason (no details were given), it failed. I've been asking around and everybody's telling me that, most probably, the registry got corrupted, and that if it cannot be restored, the best thing to do is to reinstall Windows. Any suggestions? My O.S. is Win98 and I connect via ADSL thru a Linksys router. Norton Antivirus and Zone Alarm Firewall are installed. Thanks in advance.
     
  2. Opie C.

    Opie C. Thread Starter

    Joined:
    Oct 8, 2003
    Messages:
    2
    I forgot to mention that the first thing I tried was to restore the quarantined files from the Ad-aware program, which obviously didn't solve the problem.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/171048

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice