1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Awful perfomance with Club3D 3870x2

Discussion in 'Hardware' started by GoBBLeS666, Mar 31, 2008.

Thread Status:
Not open for further replies.
  1. GoBBLeS666

    GoBBLeS666 Thread Starter

    Joined:
    Jan 25, 2008
    Messages:
    18
    I've just bought a Club3D 3870x2 and i can't get it to perform like i've seen other ppl get it to(3dmark and on forums).

    I uninstalled the old geforce 7300gs software, booted up in safemode and cleaned up with Driver Sweeper from guru3d.
    Then i installed the 3870X2 with the newest drivers from ati(3.3).


    In 3dmark '06 i get about 5500s point and the same in the '05 edition.

    All games stutter badly in different situations, and performs badly overall, even when lowering the graphics details and resolution.
    A game like Hellgate:London can't even get higher than ~20FPS. I had higher FPS with my old gfxcard(the 7300gs!!).

    UT3 runs like crap too, most other games too..


    I've also tried the Cat 8.3 hotfix driver, but it doesn't seem to make any difference...


    Somebody's got a suggestion?

    I've tried CPU-Z here's what i got:
    [​IMG]
    [​IMG]

    As you can see, both drivers are for XP, and the first one is even a generic XP driver...

    I can't get it to install the actual Vista driver in any way it seems... Donno what to do..


    Another thing is that after i installed the card, one logical CPU runs at 60-90% all the time, without anything actually using it, from looking at the Taskman:

    The top 'process' is the 'idle thing':
    [​IMG]

    Here you can see that at the same time that it uses alot of CPU:
    [​IMG]
     

    Attached Files:

  2. GoBBLeS666

    GoBBLeS666 Thread Starter

    Joined:
    Jan 25, 2008
    Messages:
    18
    Ok i ended up reinstalling Vista, and the problem is gone.

    Though if anyone would know the reason for this, i'd be happy to hear it :)
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/699090

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice