1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Backup fails in Vista-cannot find backup device

Discussion in 'Windows Vista' started by Jukie, Jan 26, 2009.

Thread Status:
Not open for further replies.
  1. Jukie

    Jukie Thread Starter

    Joined:
    Mar 21, 2000
    Messages:
    97
    Hello,
    My Vista backup is no longer backing up. It fails because it says drive "L" cannot be found. Well, my external drive is labelled "J," and has been for the past year when I've successfully backed up my hard drive. When I attempt to change the settings to back up to drive "J," it just says "looking for backup devices," and just keeps going on forever, never finding "J." I can see J in windows explorer, and it seems to be functioning just fine. Any ideas on how to get it to find drive J again?
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/794562

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice