1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

"BAD PBR" Won't boot up computer

Discussion in 'Hardware' started by constant, Mar 25, 2008.

Thread Status:
Not open for further replies.
Advertisement
  1. constant

    constant Thread Starter

    Joined:
    Jul 21, 2003
    Messages:
    198
    I am on my other computer typing this. I am having a problem on my other dell computer a little older then this one.


    I just recently got this error, and now i can't load up windows at all. When i boot up it goes to a dell blue screen. I'm running a Dell Dimension with Windows XP2...Anyways, i get the blue dell screen and then it says "loading pbr for descriptor 2..done" and then underneath it says "bad pbr" I booted up to windows xp disk and ran chkdsk and it says there's "numerous errors on the drive that are unrecoverable" So, I did a search online and saw that there is a ctrl F11 option i can push when the dell blue bar comes up that will wipe out all my files and just restore what the computer came with. It won't delete any of the drivers either. Is this a good option now or does anyone know anything else i could do to get my computer functioning correctly again. I saw there is a lot of dos apps made for repairing bad sectors in partitions, maybe i should try that. This computer doesn't have a floppy-drive though it's closed off..never came with it. Maybe i can burn the data to cd and then boot on windows xp disk, and then try and run the utility from there. I don't know why i am getting this error now. It really just came out fo nowhere, but i did just recently install new memory and i have installed a ""Wireless adapter" too. I was getting an error with that that would cause a memory dump every once and awhile. I reinstalled the driver and i thought i fixed that problem, but i just recently received it again today right before it restarted and gave me the "PBR Message" before that I didn't getthat error for a couple months. Well, now i just need some help on how to repair this problem, or if you think i should go with the ctrl F11 method??
     
  2. AlvinPCA

    AlvinPCA

    Joined:
    Oct 24, 2000
    Messages:
    42
    If it sounds like that the hard drive is going bad, you might as well replace it with a new one. You can probably boot off the xp cd and go to recovery console which will put you in DOS mode then run 'chkdsk' and see if it can repair it. If not, just start off fresh with a new drive, install xp and your apps, then just slave your old drive and see if you can recover any data that you might need.
     
  3. jazz3000

    jazz3000

    Joined:
    Apr 19, 2007
    Messages:
    2,503
    This is from another forum but should answer your question: from the Dell forums:here (http://forums.us.dell.com/supportfo...drive&message.id=98425&query.id=289253#M98425) and here (http://forums.us.dell.com/supportfo...drive&message.id=46086&query.id=289642#M46086)

    "Loading PBR for descriptor 2 ... failed" would be the exact error message if the MBR is unable to load the partition boot record for the second partition. There may be more, but here are three possible causes:
    the partition table is corrupted so that the descriptor points to the wrong place (i.e., says the partition is one place when it's really somewhere else);
    the partition table descriptor points to the right place, but the boot record there is corrupted or has been erased;
    the hard disk is failing and having trouble reading the sector with the boot record.
    To check (1), visit www.goodells.net/dellrestore/fixes.htm and download my dsrfix utility. Use it to capture a logfile and email the logifle to me for review. In short, if dsrfix reports a clean bill of health, then (1) isn't the problem.

    To check (3), run hard disk diagnostic tests. Press F12 when the machine is starting and see if the bios boot menu offers you a hard disk diagnostic test that you can run. Or even better, if you know the brand of the hard disk, most manufacturers should have a free diagnostic utility you can download to test the hard disk.

    If it's not (1) or (3), then use Ctrl+F11 to run the Dell restore utility to recreate the Windows partition.



    "Bad PBR" means the partition boot record the MBR is trying to load has an invalid sector signature.

    Right before that message, you should see something like "Loading PBR for descriptor 2". That will tell you which PBR the MBR is having a problem with--descriptor '1' is the Dell Utility partition, '2' is the XP partition, and '3' is the Dell Restore partition. Let us know...Jazz
     
  4. constant

    constant Thread Starter

    Joined:
    Jul 21, 2003
    Messages:
    198
    Well it says it's a bad PBR not that it failed, and it is the descriptor 2 which is the XP partition. It loaded succesuffuly, and then tells me the PBR is bad. I was thinking of running the Recovery install on the Windows XP disk, and see if that fixes the problem. Otherwise i'll try some of the these fixes. I think i ran a harddrive diagnostics earlier, but i'll do that again. I'm not sure how i would get the fixes to run though because i don't have a floppy-drive on that computer just a cd-drive. I ran the chkdsk from the windows xp recovery console earlier and it gave me that "there's numerous errors on the hardrive that are unrecoverable" I would rather not have to reformat the hardrive, but i don't have a ton of important files on there so it's not going to matter too much. I might try the "bootfix" option in windows recovery console too if the recovery install doesn't work. Let me know what you think about this??
     
  5. constant

    constant Thread Starter

    Joined:
    Jul 21, 2003
    Messages:
    198
    drive diagnostics were good...it found one on the primary and then two on the secondary that were unsopported by the diagnostics which is my cd/rw and cd-rom drive. Drive diagnostics isn't goign to help. I want to move on with trying what i said above. So, jazz if you think that's a good idea let me kno??
     
  6. constant

    constant Thread Starter

    Joined:
    Jul 21, 2003
    Messages:
    198
    Okay, there is no recovery install on the XP disk i have. So that option is out. I'm getting an even worse error now so i'm not sure if i can do the F11 dell restore. Now i'm getting an "Operating system not found" error and there is no blue bar dell screen coming up. I can still boot to the Wiindows XP 2 CD and i can do a install, which will format and reinstall windows XP or i can try the "fixboot" option in the recovery console and maybe that will help. That looks like it will just create another boot sector for the system partition, but not fix the one that Windows is on. I can install windows on that partition, but what is the difference?
     
  7. jazz3000

    jazz3000

    Joined:
    Apr 19, 2007
    Messages:
    2,503
    More than likely whether you like it or not your going to have to install a clean system. If we run into a problem there I'd be looking at the hard drive itself. Keep us posted...Jazz
     
  8. constant

    constant Thread Starter

    Joined:
    Jul 21, 2003
    Messages:
    198
    Well, I used the "fixboot" command in the Windows XP recovery console and it wrote a new boot sector on the C: and fixed the problem. I can run Windows now, but i am having some problems with opening Internet Explorer as well as AOL, but i uninstalled AOL all together. This isn't a hardware problem so i won't post it in here. Thanks for the help, the one link you posted from another site jazz helped and I printed that out.
     
  9. jazz3000

    jazz3000

    Joined:
    Apr 19, 2007
    Messages:
    2,503
    Glad to hear your up and running. You might try repairing Internet Explorer. That's easy enough. Let us know how it's going....Jazz
     
  10. techchic777

    techchic777

    Joined:
    Apr 6, 2007
    Messages:
    12
    Hey...I'm having the same problem with my computer, so how do I get to the Windows recovery console? I had three errors in two sectors. Any ideas? please help. I'm off work today and would like to get back online with this computer ASAP. Thanks!
     
  11. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/697026