Battlefield 2 doesn't like Windows 7

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

BlueLegit

Thread Starter
Joined
Dec 8, 2009
Messages
9
Specs:

Processor: Intel(R) Core(TM)2 Duo CPU E7300 @ 2.66GHz
RAM: 3.0 GB
Graphic: GeForce 9600 GSO 512 (1 GB video memory)
DirectX: 10.0
OS: Microsoft Windows 7 Ultimate Edition (build 7600), 32-bit

Well I'm pretty sure the issue has been up before and I've seen endless of topics with this problem when I search google, but for some reason all the solutions mentioned either did not work for me or the topic pretty much ended blank.

To fill you in on the problem it's pretty simple. Battlefield 2 shows a black screen on startup for about 2-4 seconds and then returns to desktop with no error message.

I made a clean installation of the game and tried running it. That went fine. I updated to 1.41 and that's when the black screen starts shouting. I then also tried updating to 1.5 but the black screen continues.

Now the steps I've tried to do consists in editing both the audio.con and video.con to fit my screen preferences as in resolution and hertz. Also tried running the game as administrator, different compatible modes as well as the other different checkboxes in the compatibility tab. Even None of these steps worked for me.

I've got the latest chipset drivers as well as graphic drivers and what not. DirectX 10 and up to date as well as pretty much anything that could affect it.
-----------------------------

So all I'd like to know is if there is anyone who know of a different solution that might help me in this case. :)
 
Joined
May 14, 2010
Messages
1
This explains my issue exactly. Black screen for a few seconds then desktop, no error messages, nothing.
I noticed this started happening right after updating Punkbuster. I have no clue if that has anything to do with it but thats when it started. I'm also using Win 7 Ultimate like OP.
 
Joined
May 18, 2010
Messages
5
When you put the first disk in, the auto reader wants to launch. Deny it.
Open computer and explore disk.
Right click setup in disk and go to properties.
go to compatability tab and click Win xp SP3
Run as administrator
apply and click ok.

Right click setup again and choose run as admin.

open windows registry editor

Code:
for 32bit os,  it should be in:  HKEY_LOCAL_MACHINE\SOFTWARE\Electronic Arts\EA Games\Battlefield 2\ergc
for 64bit:   HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Electronic Arts\EA Games\Battlefield 2\ergc
edit your cdkey in there and add: x9392 in front of your key with no spaces.

the game should now work.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top