1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Belkin N150 router disconnects my remote desktop connection

Discussion in 'Networking' started by adrialla, May 8, 2012.

Thread Status:
Not open for further replies.
  1. adrialla

    adrialla Thread Starter

    Joined:
    May 8, 2012
    Messages:
    2
    I'm not overly tech savvy, so please consider that when responding. :eek:

    I have one desktop PC at home, Windows XP, and have a Time Warner wired modem for internet. I work from home and connect to my office computer through Remote Desktop Connection.

    I purchased a Roku2 video streaming player and bought a Belkin N150 wireless router in order to get the signal from my desktop computer out to the living area where the Roku is located. The connection with the Roku is perfect. However, my remote desktop connection now disconnects constantly and internet browsing on the local computer is very slow and choppy.

    The configuration I used is 1) Belkin ethernet wire from Belkin to back of modem 2) modem ethernet wire from Belkin to computer.

    If I remove the Belkin and put everything back the way it was, all is fine ... but, of course, we then have no Roku. I can't imagine that I should have to disconnect the Belkin for me to access my office computer without issues, which in turn prevents those in the living area from using the Roku.

    I have spoken to Belkin's customer support, they had me change settings 3 different times. Bottom line is Belkin's CS is script oriented and they have no clue otherwise.

    Any thoughts from this forum would be most welcome.

    Thanks so much.
     
  2. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    76,842
    First Name:
    Terry
    Make sure you have the latest router firmware; then reset the router to factory default settings and reconfigure it. (If you already have done both of these in this order you need not do them again.)

    When you get a disconnect do the router (or modem) LEDs give any hint of whether the disconnect is between modem and router or between router and computer?

    Consider that either of the ethernet cables may be defective.
     
  3. adrialla

    adrialla Thread Starter

    Joined:
    May 8, 2012
    Messages:
    2
    The first 2 suggestions were already done. I actually went to the length of uninstalling Belkin program and reinstalling. But the problem still exists.

    When there is a disconnect (or freeze-up), both the modem and router LEDs are indicating that all is well. If I disconnect from Remote Desktop Computer and launch it again, it's fine ... for about 3 minutes. As mentioned earlier, it also makes my local internet connection painfully sluggish. I will exchange the Belkin and see if the problem persists ... or buy a higher end router.

    It's curious that it works perfectly for the Roku ... no faltering at all and very quick speed. It just causes a problem with using the computer. Someone suggested I get a Netgear router.

    Thank you for your suggestions! :)
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1052455

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice