1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Belkin Wireless causing problems with web server

Discussion in 'Networking' started by aspaddict, Jan 9, 2005.

Thread Status:
Not open for further replies.
  1. aspaddict

    aspaddict Thread Starter

    Joined:
    Jan 9, 2005
    Messages:
    2
    Greetings all - Im hoping someone can assist with this issue since I cant seem to figure it out.

    We just moved to a new place and decided to use wireless networking instead of running cables across three floors of living space. I have a Win2K server running IIS that hosts about four small websites and a very basic email server. We purchased a Belkin wireless router and a couple of wireless USB adapters for the PC and everything works great except that I cannot get to any of the websites on my server if I am at home - all I get is the Belkin router configuration page when I go to any of the URL's on my server. If I am at work, they pull up just fine.

    This is what I've tried so far:
    • Moved one machine to the DMZ - still couldnt view it
    • Tried different DNS servers
    • Changed the order of my DNS servers

    None of these seems to help the situation at all - anyone on my internal network still sees the Belkin router config page instead of the websites...any suggestions??

    Thanks in advance!
     
  2. squidboy

    squidboy

    Joined:
    Dec 29, 2004
    Messages:
    403
    That is odd. I'm suspecting a DNS issue, probably within your router. Open a cmd prompt from one of the PC's.

    Can you ping the web address by name?
    Can you ping the Windows server by IP address?

    Also, do you have a name space set up in your Windows server? How are DNS names resolved from your ISP to your internal web hosts?
     
  3. aspaddict

    aspaddict Thread Starter

    Joined:
    Jan 9, 2005
    Messages:
    2
    I figured out the problem, but to answer your questions:

    Yes, I can ping by name
    Yes, I can ping the Win server by IP
    Name spaces, I dont think I have those setup...

    The way I used to do it (before going to wireless) was to have all the machines in the house log on to the domain, and they would automagically get the correct DNS entries - everything worked fine. When we upgraded to the wireless router, it comes with its own DHCP server built in, and you can set up virtual servers, which essentially route requests for specific traffic to an internal IP. The wireless router actually holds the IP that the rest of the world sees (12.xxx.xxx.xxx) then forwards the requests to the internal IP of the server (192.168.xxx.xxx) - this is what was failing.

    I found a fix, although its not exactly what I hoped it would be - I had to edit the hosts file in the c:\%windir%\system32\drivers\etc folder and add the internal IP (192.168.xxx.xxx) address of my webserver and the domain names to that file. I think its kind of odd, though, since my machines could already resolve the correct IP for the websites...the Belkin router seems to have hijacked my server. Im guessing that this might be because the router is intended for home users, not business users. I suspect a more expensive, business oriented model would have performed just fine. *grin*

    In any event, I hope this helps to serve someone else in the future!
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/317261

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice