Brother printer drivers not installing on HP laptop

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

dawgbonz

Thread Starter
Joined
May 1, 2019
Messages
1
Greetings,

About a month a program called HP Support Assistant showed a long list of updates that needed to be installed on my HP laptop so I let the various updates install. There was at least 15 or so updates that ran. After the updates my laptop could no longer print to my Brother MFC-7860DW printer. I went to the Brother site and it said to uninstall and reinstall the Brother printer drivers. I was able to get the drivers to uninstall but when I try to reinstall the drivers it just sits there and does nothing. The 'Brother Printing Device Installation' Box appears and tells me to plug the printer into the computer and turn on the printer and wait for the installation process to continue but nothing ever happens. Below is the info on my laptop. Thanks for any help/advice you can provide.

Tech Support Guy System Info Utility version 1.0.0.4
OS Version: Microsoft Windows 10 Home, 64 bit
Processor: Intel(R) Core(TM) i3-7100U CPU @ 2.40GHz, Intel64 Family 6 Model 142 Stepping 9
Processor Count: 4
RAM: 12204 Mb
Graphics Card: Intel(R) HD Graphics 620, 1024 Mb
Hard Drives: C: 916 GB (764 GB Free); D: 13 GB (1 GB Free);
Motherboard: HP, 832A
Antivirus: Norton Internet Security, Enabled and Updated
 

Oddba11

Jim
Joined
May 12, 2011
Messages
8,338
Do you have the printer disconnected during the install until you are told to connect it? If not, that will cause an installation issue. I've had similar issues with Canon software.

Aside from that, uninstall ALL HP drivers and software, reboot, and then perform a fresh install following the instructions provided by Brother. You have two choices here, use the original installation disc or use the latest package available from HP. I would typically recommend using the latest version. If that doesn't work, then uninstall again, reboot and use the original (as those are likely what was in use before this all started and should work).
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top