Camera will not show picture on screen

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

djlanga

Thread Starter
Joined
Nov 23, 2006
Messages
49
Well, what the title says...my camera's screen is grey when it is turned on, although I can still take pictures with it. The camera is a Sony DSC-S40 just to let you know. I don't know if it is the camera's inside hardware or the software that is creating the problem.
I want to know if I can fix this before sending it to Sony. So, if there is no help you can give me, is there anywhere else you can recommend to find a possible solution to this problem?
Thanks(y)
 
Joined
Jun 27, 2000
Messages
6,832
Have you pushed the “Monitor” button to the lower left of the 4-way buttons? It cycles the display on and off. Can you see anything when you press the Menu button?

Assuming you know about the monitor switch you are probably going to find your LCD isn’t going to work. There is no menu setting I can think of that would cause the LCD to not display when you cycle the monitor switch.

And if you can’t see anything in menu mode the camera will have limited utility even though it has an optical viewfinder.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top