1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

"cannot find the file specified" "during the installation of the device."

Discussion in 'Windows XP' started by DaveBurnett, Jun 5, 2004.

Thread Status:
Not open for further replies.
Advertisement
  1. keyboardcook

    keyboardcook

    Joined:
    Sep 25, 2007
    Messages:
    1
    The best solution I have ever come across. Was trying to insall my Roland Fantom X. I registered to thank you, and also put the keyboard name on the page to help other roland owners who search for the solution to the problem.
     
  2. techie_amar

    techie_amar

    Joined:
    Oct 12, 2007
    Messages:
    1
    Thanks a lot, this resolved my issue:) :) :) :) (y)
     
  3. Jeruvy

    Jeruvy

    Joined:
    Sep 20, 2007
    Messages:
    568
    Any idea's on what might be doing this? Cleaner or something? I've never had this happen myself but its quite interesting nonetheless. One person seemed to indicate it happening after malware removal. Perhaps someone using a registry cleaner, never a good idea.

    It may also be worth noting that you can acquire tools that will protect certain keys from being manipulated or changed or even deleted. Now if this was being bypassed I'd be even more intrigued.
     
  4. pc_fixer

    pc_fixer

    Joined:
    Nov 26, 2007
    Messages:
    3
    I also registered just to say thank you. I tried to install an usb sky caddie for a customer and it never worked. I disabled the firewall, any security software, did a complete check over the dell website, tried a dozen driver websites, but nothing worked. I almost gave up and brought the Dell laptop back without fixing the problem. The last try was to google the problem and I came across your fix. Wow, after adding the RunOnce key, everything was working perfectly.
    Thanks David for that tip, its a lifesaver.
     
  5. mannagills

    mannagills

    Joined:
    Dec 31, 2007
    Messages:
    1
    Struggled for hours trying to install a Samsung ML-2510 printer until I found your tip. Thanks. I was minutes away from packing the printer up and returning it to the store.
     
  6. DaveBurnett

    DaveBurnett Dave Trusted Advisor Thread Starter

    Joined:
    Nov 11, 2002
    Messages:
    11,669
    There are several possibilities - and I haven't spent the time investigating them to find out which.

    Anything under the RunOnce key is supposed to be run and then deleted.
    I don't know who deletes the entry. It may be MS. It may be the program that gets run. It may actually be both. Whoever is doing it is not doing the correct check to see if the key exists ( I believe) and is deleting a none existing keyvalue and is therefore deleting the Runonce instead.


    But don't take my word for it.
     
  7. tfmorris

    tfmorris

    Joined:
    Jan 20, 2008
    Messages:
    1
    Another big thank you!

    After decades of working with computers I'm amazed that we still have to deal with crap like this.

    Engineers who create uninformative and misleading error messages like this (calling a registry key a "file" and not including the name of the key) should never be allowed near a keyboard again!

    Tom

    p.s. In my case I suspect it was either a NetGear or Buffalo wireless installer that was the culprit.
     
  8. cnfcomps

    cnfcomps

    Joined:
    Apr 27, 2008
    Messages:
    1
    Thank you very much for sharing this useful tip! It fixed a problem where a Sagem F@st 800 USB ADSL modem would not install properly.

    Matt.
     
  9. Azuredevil

    Azuredevil

    Joined:
    Apr 30, 2008
    Messages:
    1
    Put another mark in the "Registered just to say thanks" column. A buddy spent all day yesterday trying to fix this issue with an HP All-In-One and this took care of it.

    Good thing too, I think he might have lost it while working on it today.

    Thanks again.
     
  10. alik713

    alik713

    Joined:
    Jul 8, 2008
    Messages:
    1
    Another "Registered just to say "Thank You"!"
    :D
     
  11. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/235959