Cannot Get Brand New USB External Hdd to Work?

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

pezmc

Thread Starter
Joined
Sep 9, 2007
Messages
14
I just bought a brand new WD Scorpio WD1600BEVE 2.5-inch EIDE Hard Drive (Here) and a Sumvision Usb 2.0 Wxte-e 844 2.5" Enclosure for it to go into.

However when I plug it into my laptop (both cables into two different use ports). It recognises it and installs drivers. It doesn't show up in device list, so I went to device manager and it was functioning correctly, I then went to hard disk management and it was not initialised or formatted. Howver I cannot initialise (no button appears on right click), and I cannot format as this is greyed out.

Please help me! :p
Thank you,
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top