1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

cannot install any new USB device

Discussion in 'Hardware' started by sequoia55, Nov 12, 2006.

Thread Status:
Not open for further replies.
Advertisement
  1. sequoia55

    sequoia55 Thread Starter

    Joined:
    Nov 12, 2006
    Messages:
    1
    I've tried installing USB devices recently and for all new USB device installation, I get an error message that says:
    "There was a problem installing this hardware:
    USB 2.0 Hub controller (or shows the appropriate USB device)
    An error occurred during installation of the device.
    The data is invalid"

    This message came up when I tried to install a D-Link 4 port USB hub. I'm able to install the hub on other computers with no problems. I've tried this USB hub on all USB ports on my laptop - no difference. I do have other USB devices that are working OK on this laptop so I know USB does work.

    I've also had a similar problem recently preventing me from installing any/all USB devices including a USB memory card reader, a USB Logitech webcam, etc. I get the same line at the end of the error that states "The data is invalid".

    The USB hub controller installation tries to use Windows 'Generic USB Hub' driver for the installation. It shows up in Device Manager as a 'USB 2.0 Hub Controller' so the device is being recognized correctly, just not installing the driver correctly. The Logitech USB webcam shows up as a 'USB device' in Device Manager but it does say 'Logitech USB Camera (Fusion)'.

    Any suggestions on what may be causing the error "The data is invalid" and blocking all USB device installations? Any ideas on how to correct this problem?

    My system is a Compaq Presario R4000 laptop (Athlon 64) with Windows XP Pro SP2. USB devices I have installed and working correctly are a IOGear USB 7-port hub, USB external HDD, USB KVM, USB printer.
     
  2. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
    First set a System Restore point and test it: start > run: msconfig > Launch System Restore.

    The standard approach to these problems is to remove all the USB devices in the Device Manager and let Windows reinstall them. But there is a special technique to it.

    I am uploading a registry patch you will need to download, unzip and run. Confirm the merge to the registry.

    It is the patch described in JohnWill's note here:

    http://forums.techguy.org/hardware/449735-usb-problem.html#post3435808

    Once you have installed the patch, follow the rest of his instructions.

    Note: in some cases Windows does not have the proper install path for the information files required. If the New Hardware Wizard prompts you for an install location, point it to:

    c:\windows\INF

    or if c is not your root drive just use %systemroot%\INF

    This is a hidden directory, so you will need to have "show Hidden Files" enabled in Folder Options > View to see it.
     

    Attached Files:

  3. gfxrelay

    gfxrelay

    Joined:
    Oct 26, 2005
    Messages:
    588
    Your USB ports are haunted! Who you gonna call? Does it do it with all of your USB ports or just some. It could be a driver issue or a blown port. Go into the device manager. If you see a yellow exclamation mark next to the usb devices it is just a driver issue. If not it could be that he ports are blown
     
  4. Rich-M

    Rich-M

    Joined:
    May 3, 2006
    Messages:
    22,417
    If I read this correctly, I cannot help but wonder if a laptop can power 2 usb hubs to begin with. Aree both connected at same time?
     
  5. rarprior

    rarprior

    Joined:
    Jul 16, 2007
    Messages:
    1
    I have the same issue though my motherboard seems ok thankfully!

    after using the reg. file and proceeding with the unistalling of the usb drivers, rebot. Now im being presented with the same problems...

    The usb root hub went in ok but the individual usb controllers when installing came up with the data invalid error!

    Im at a loss of what to do and will try anything to avoid reinstalling windows...
     
  6. gfxrelay

    gfxrelay

    Joined:
    Oct 26, 2005
    Messages:
    588
    It seems to be a problem between Windows and some USB devices I get the same error when I try to install a printer on my computer I think the only way to repair this is to re-install windows:confused:
     
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/517795