1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Canon Multipass C530 cannot reinstall

Discussion in 'Hardware' started by daizee97, Feb 5, 2003.

Thread Status:
Not open for further replies.
  1. daizee97

    daizee97 Thread Starter

    Joined:
    Jan 27, 2003
    Messages:
    30
    I have searched everywhere for information on how to fix this and all I can find on the internet is how rotten these multipass printers and their softwares are!

    The computer in question had crashed several times, so I had bought a new hard drive, reinstalled the OS and copied over several folders from the old hard drive (which I added as a slave drive in case Mom ever needs to find any of her old crap). I only copied over folders that seemed necessary and safe (for instance, no program files were copied over, we opted to reinstall everything new).

    Everything seemed okay except two things: first, I could not install MS Office 2000 (turns out I needed to download the windows installer update from microsoft.com) and second, the canon multipass would not install. It seems fail when trying to install the desktop manager software. We tried downloading the driver package from Canon's website to no avail. I've scoured the downloads and CD and sought out the driver files and individual exe's, but without desktop manager installed, the printer does not function. I keep getting the same error "Unknown Model Key". The thing that kills me is that there are NO (on Canon's site or searched on Yahoo, DogPile and countless other engines) references to "Unknown Model Key".

    I found one place that offered a registry cleaner, but the download link was dead! And of course, it would be too convenient if Canon offered that or if they would tell you where each file is installed to and what registry keys are affected.

    HELP!
     
  2. onedav

    onedav

    Joined:
    Dec 11, 2003
    Messages:
    1
    Hi!

    I too have been getting the same message "model key unknown". However, after repeating the install several times the driver software (from canon download) would finally come up! Now, the problem is another message comes up "failed to register devices in NT devices and servic.exe".

    By the way, the extractor extracts the files to "C drive..Temp" if you want to follow the path of the files.

    Good luck,
    Dav
     
  3. Triple6

    Triple6 Moderator

    Joined:
    Dec 26, 2002
    Messages:
    52,926
    First Name:
    Rob
    Almost sounds like the Windows install didn't go quite right and maybe you're mising a few things.

    Since its a new install I would format and reinstall agian, then install the latest motherboard chipset drivers from the motherboard or the chipset manufacturer's site, then downlaod all the Windows Updates(except driver updates) and then start installing your Office and Canon Stuff (with the latest drivers from Canon and also don't have the Canon plugged in until you are prompted to connect it.)
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/117161

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice