1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Can't connect to internet, DHCP Client won't start, and can't use system restore.

Discussion in 'Virus & Other Malware Removal' started by SickOfThisPoo, Dec 21, 2011.

Thread Status:
Not open for further replies.
  1. SickOfThisPoo

    SickOfThisPoo Thread Starter

    Joined:
    Dec 20, 2011
    Messages:
    1
    I'm not sure what techinal mumbo jumbo info you need, but I do know that you at least need that I have windows XP Service pack 3

    The system restore is simple. I start it up, it runs, I log back in, and then I get a message without any error codes that it could not be compleated, and that no changes were made. When checking what is affected (since, when attempting a system restore, I get a message that says "Changes made to drive(s) E: after this point cannot be reversed because the drive was either excluded from System Restore monitoring, or was turned off or removed"

    In any of the lists I find, it seems system restore only affects C: anyways.

    I have a feeling that if I turn the restore points off then on, therefore reseting them, or create custome restore points, it would be fine, but I also have a feeling that a good system restore would fix my other, more complex problem. And if I can do a system restore in the end and fix this, I need those old restore points.

    (Also, I have attempted system restore from various points from both normal and safe mode, and at no point was there a change in what happened.)

    When going through run to the event veiwer to check system restore errors, there was one for each attempt at a system restore, all with the Source: SRService, Event ID: 111, and the message in the description :

    "A restoration to "Software Distribution Service 3.0" restore point failed. No changes made to system.


    For more information, see Help and Support Center at
    http://go.microsoft.com/fwlink/events.asp"





    This problem should not be a problem for me should I be able to fix the other problem, because then I will be more than willign to create brandnew restore points. Also, this is a hand me down computer, and I do not know if norton was ever on it. I have avast, and I did go to settings and turned off "Enable avast! self defense module" and attempted several restores under various circumsance, including safe mode.


    On to my real problem.


    Exclusivly on this computer, a laptop, when trying to access the internet through both lanlines and wireless, I get an eternal "Aquiring Network Adress" message, and no access. Attempts at refreshing through the command prompter as I have been told the most common solution led to error messages. Much hunting latter, I found that through control panel, then administrative tools, then services, And finding my DHCP Client, that the DHCP Client (Which, reading the descripition "Manages network configuration by registering and updating IPaddresses and DNS names, I realised should be on) Was turned off.

    Upon hitting "Start the service", I got the message

    "Could not start the DHCP Client service on Local Computer.

    Error 1075: The dependency service does not exist or has been marked for deletion."

    Hunting around for that error led me to this.

    http://kaliphonia.com/content/windo...rvice-does-not-exist-or-has-been-marked-for-d

    of which I tried the first option and failed, with some weird pages opening up at the end, Something with a lot of little boxes with diffrent lables, and the options to like, cancel and "connect" and such.

    I'm sorry, it was a while ago, and I was too scared to mess with it again.

    then I tried this.

    http://support.microsoft.com/kb/915162

    under the registery edditer option, and all three DependOnService Entires were there and I don't know what they mean by step 4.

    And now I'm stuck. I know I have to get that DHCP thing started, that will do it, but I can't figure out why it wont turn on in the first place.

    AH! And also, I'm sortof blaming avast!, becuase I'm sure that I saw something distincly not virus looking slip by on the deletion list. It looked very suspiciously like the deleated driver this woman encountered, though I can't be 100% sure... more like... 80% sure....http://www.techsupportforum.com/forums/f10/dhcp-error-1075-a-613687.html

    If Avast! deleated one of my registry keys... *grumble*

    I am very, very tempted to get out an old Windows XP Cd, strip off my photo's on a friends flash drive, and start all over.

    Please, if you are to offer a solution, while I'm sure I could do it, I will need step by step instructions, every click as it were. And any informatino needed, I will similarly need their exact location in my system.

    Thank you very much for your prompt response.

    EDIT:

    Under Services, in Administrative tool, I was gathering some of the information that people with similar problems have needed and found that TCP/IP Netbios helper would also not start.

    Both have something called "AFD" under dependencies, but I don't know what that is, while DHP Client also had TCP/IP Protocol Driver and within that, IPSEC driver in it's dependencies, but I think since TCP/IP... had only AFD listed, that might be the problem.

    I was also looking through the even veiwer, and got some of these messages under "information type: error" on the day it stoped working.

    Source : Service Control Manager, Event ID: 7003, Description:

    The TCP/IP NetBIOS Helper Service depends on the falowing nonexistent service: NetBT

    For more information, see Help and Support Center at
    Http://go.microsoft.com.fwlink/events/asp

    There was a second, identicle (replacing TCP/IP NetBIOS Helper Service, with "DHHCP Client service") error messege as well.
     
  2. haiden

    haiden

    Joined:
    Dec 20, 2011
    Messages:
    55
    Unauthorized content removed.
     
  3. Cookiegal

    Cookiegal Administrator Malware Specialist Coordinator

    Joined:
    Aug 27, 2003
    Messages:
    115,815
    First Name:
    Karen
    haiden,

    I've removed the content of your post as you're not authorized to assist with malware removal. Please refer to the site rules:

    http://www.techguy.org/rules.html
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1032218

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice