1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Can't connect to internet wirelessly - Atheros AR9285 Wireless Network Adapter7

Discussion in 'Web & Email' started by highlystrung, Mar 8, 2011.

Thread Status:
Not open for further replies.
Advertisement
  1. highlystrung

    highlystrung Thread Starter

    Joined:
    Apr 11, 2006
    Messages:
    15
    I have a labtop on which I run windows 7 and normally connect to the internet wirelessly. However, after having run Iolo system mechanic 7 to try and ensure my computer is in good shape, my Atheros AR9285 Wireless Network Adapter is showing a big red cross by it and says "Not connected" so I can't connect wirelessly to the internet. Being an amateur computer user I've tried "diagnose this connection" etc.. but to no avail. Can anyone enlighten me on how to get it working again? thanks, Neil
     
  2. pedroguy

    pedroguy

    Joined:
    Jan 28, 2001
    Messages:
    6,523
    Ok:My initial guess would be that the mechanic took a "wrench" to the registry or some system files.
    So let's see this:
    Let’s take a look at the status of the network adapters

    Device manager:

    Hold the Windows key and press R, then type devmgmt.msc

    Please respond to all the following steps.
    1. Under Network adapters, please tell me all the devices listed.
    2. Are there any devices under Network adapters that have a red x displayed?
    3. Also, are there any devices anywhere in the Device Manager display with yellow ? or ! displayed?
    4. should be enabled and working properly.
    5. If error code,what is it ?

    It would be best if you could post a screen shot of Device Manager with the Network adapters and Other devices sections expanded.

    To post a screen shot of the active window, hold the Alt key and press the PrtScn key. Open the Windows PAINT application and Paste the screen shot. You can then use PAINT to trim to suit, and save it as a JPG format file. To upload it to the forum, open the full reply window and use the Manage Attachments button to upload it here.

    Look at the driver section.Note down driver name,version and location.
    I would go to your laptop maker's web site,download and install in this order:
    Any chipset driver available for your model
    And:
    Then the wireless adapter driver appropriate for your laptop.
     
  3. highlystrung

    highlystrung Thread Starter

    Joined:
    Apr 11, 2006
    Messages:
    15
    Here's a view of device manager attached - no issues displayed in Device manager...

    Looked all through the Device manager and no other issues obvious (red x, yellow or ! displayed)

    I think I've attached the pics. I'll do the last bit of your advice if you confirm from this information.

    Thanks for your help so far,

    Neil
     

    Attached Files:

  4. pedroguy

    pedroguy

    Joined:
    Jan 28, 2001
    Messages:
    6,523
    Ok: Let's see this:
    Start, Run, CMD, OK to open a command prompt:
    (For Vista or 7 type CMD in the Search box after Start)



    In the command prompt window that opens, type the following command:

    Note that there is a space before the /ALL, but there is NOT a space after the / in the following command.

    IPCONFIG /ALL

    Right click in the command window and choose Select All, then hit Enter to copy the contents to the clipboard.
    Paste the results in a message here.

    If you are on a machine with no network connection, use a floppy, USB disk, or a CD-RW disk to transfer a text file with the information to allow pasting it here.

    And make sure that all network tasks are started.



    Check your Services are Started on all PCs:
    • COM+ Event System (for WZC issues)
    • Computer Browser (computer browser will start when needed)
    • DHCP Client
    • DNS Client
    • Network Connections
    • Network Location Awareness
    • Remote Procedure Call (RPC)
    • Server
    • TCP/IP Netbios helper
    • Wireless Zero Configuration (XP wireless configurations)
    • WLAN AutoConfig (Vista wireless configurations)
    • Workstation

    Note: You can check the services in Control Panel, Administrative Tools, Services.

    All of these services should be started, and their startup type should be automatic
    If a service is not running, open it's properties and check the dependencies. Check each of the dependencies and see which one is preventing the service from running. Checking the event log is also a good idea here, there may be clues to what is failing.
    __________________


    And,just to make sure that there is no stack corruption .
    Stack repair for XP and Vista.
    Courtesy of Johnwill of the Networking forum.

    TCP/IP stack repair options for use with Windows Vista.

    Start, All Programs\Accessories and right click on Command Prompt, select "Run as Administrator" to open a command prompt.

    In the command prompt window that opens, type type the following commands:

    Reset WINSOCK entries to installation defaults: netsh winsock reset catalog

    Reset IPv4 TCP/IP stack to installation defaults. netsh int ipv4 reset reset.log

    Reset IPv6 TCP/IP stack to installation defaults. netsh int ipv6 reset reset.log

    Reboot the machine.

    And then let me ask the "dumb" question.
    Are you sure that the wireless switch is on.The wireless activity light is on ?
     
  5. highlystrung

    highlystrung Thread Starter

    Joined:
    Apr 11, 2006
    Messages:
    15
    Here's the paste:

    Microsoft Windows [Version 6.1.7600]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.

    C:\Users\Owner>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : Owner-PC
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Realtek PCIe FE Family Controller
    Physical Address. . . . . . . . . : 40-61-86-B2-98-C7
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::c906:f8b8:441f:6e96%12(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.0.2(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : 08 March 2011 17:32:07
    Lease Expires . . . . . . . . . . : 08 March 2011 20:47:38
    Default Gateway . . . . . . . . . : 192.168.0.1
    DHCP Server . . . . . . . . . . . : 192.168.0.1
    DHCPv6 IAID . . . . . . . . . . . : 289431942
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-47-2B-52-40-61-86-B2-98-C7

    DNS Servers . . . . . . . . . . . : 194.168.4.100
    194.168.8.100
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Wireless LAN adapter Wireless Network Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Atheros AR9285 Wireless Network Adapter
    Physical Address. . . . . . . . . : 1C-4B-D6-FA-A2-1F
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fd:1402:2b39:c101:bb2d(Pref
    erred)
    Link-local IPv6 Address . . . . . : fe80::1402:2b39:c101:bb2d%15(Preferred)
    Default Gateway . . . . . . . . . : ::
    NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter isatap.{6C9BE9D9-460A-4B84-AFF8-93DD3DDF58D8}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{EC263DC8-9CD6-4F9D-8FAF-A08F074B2983}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #4
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    C:\Users\Owner>

    Not exactly sure what all this means....Your next instruction: "And make sure that all network tasks are started." - sorry don't understand this! Can you explain more...?

    Neil
     
  6. pedroguy

    pedroguy

    Joined:
    Jan 28, 2001
    Messages:
    6,523
    Ok: Dhcp is not enabled.on the wireless connection.
    From a Johnwill postConfigure DHCP for Windows Vista.
    1. Click on the Start menu, and select Control Panel.
    2. Click on Network and Internet. (Skip this step if you do not see this Control Panel item.)
    3. Click on Network and Sharing Center.
    4. Click on Manage network connections.
    5. Right click on Local Area Connection and choose Properties. If Windows say it needs your permission to continue, click Continue.
    6. Select Internet Protocol Version 4(TCP/IPv4) and click Properties.
    7. Select Obtain an IP address automatically.
    8. Select Obtain DNS server address automatically.
    9. Click OK to close the TCP/IP Properties window.
    10. Click OK to close the Local Area Connection Properties window.
    11. Click Close to close the Network Connections window.
    12. Click Close to close the Control Panel window.
    13. Restart your computer.

    As to network tasks:
    from post #4
    You can check the services in Control Panel, Administrative Tools, Services.
    We need to make sure that all network tasks,including Dhcp are enabled and running >
     
  7. highlystrung

    highlystrung Thread Starter

    Joined:
    Apr 11, 2006
    Messages:
    15
    Found bit on services - have included pic. All okay except in pic:

    some are manual
    Wireless Zero Configuration (XP wireless configurations) - not in list
    WLAN AutoConfig (Vista wireless configurations) - in list but doesn't say it's started
     
  8. pedroguy

    pedroguy

    Joined:
    Jan 28, 2001
    Messages:
    6,523
    Well done.WLAN is the wireless client manager.If not started,the address assignment process cannot get started.
    If you look at the ipconfig results for your ethernet connection,the Dhcp server has assigned valid network addressses for your wired connection.
    That's the way your wireless connection should look except for a different ipv4 address.
    Now when you start WLAN be aware that there may be some other services,that WLAN depends on that also may need to started
    So make Wlan auto start and enable it .
     
  9. highlystrung

    highlystrung Thread Starter

    Joined:
    Apr 11, 2006
    Messages:
    15
    can get to Network sharing area but can't find manage network connections (please see screen dump). Any more guidance please? - have looked at all options on this screen but it doesn't get me to Manage network connections or Local Area Connection, thanks, Neil
     

    Attached Files:

  10. pedroguy

    pedroguy

    Joined:
    Jan 28, 2001
    Messages:
    6,523
    OK;Since I do not have w7,I am going to take a guess here and have you try the setup or connect option.
    But here is something else I just saw.
    Courtesy of Terrynet on the Networking Forum

    To configure a dynamic IP address on your Windows Vista or 7 computer:



    To configure a dynamic IP address on your Windows Vista or 7 computer:

    1. Click Start.
    2. Select Network, then Network and Sharing Center, and click Manage network connections or Change adapter settings from the list of tasks.
    3. Right click the connection of interest and click Properties.
    4. Select Internet Protocol Version 4 (TCP/IPv4) from the list and click the Properties button.
    5. Select Obtain an IP address automatically.
    6. Select Obtain DNS Server address automatically.
    7. Click OK.
    8. Click Close.

    First though I would make sure that Wlan is up and running.
     
  11. highlystrung

    highlystrung Thread Starter

    Joined:
    Apr 11, 2006
    Messages:
    15
    Well WLAN is automatic now in Start up and I reset the IP address to be picked up automatically, restarted the computer but still no joy from the wireless adapter. I'm starting to lose the will to live... any ideas? Here's the IPCONFIG data again:

    Microsoft Windows [Version 6.1.7600]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.

    C:\Users\Owner>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : Owner-PC
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Realtek PCIe FE Family Controller
    Physical Address. . . . . . . . . : 40-61-86-B2-98-C7
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Wireless Network Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Atheros AR9285 Wireless Network Adapter
    Physical Address. . . . . . . . . : 1C-4B-D6-FA-A2-1F
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{6C9BE9D9-460A-4B84-AFF8-93DD3DDF58D8}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{EC263DC8-9CD6-4F9D-8FAF-A08F074B2983}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #4
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    C:\Users\Owner>
     
  12. pedroguy

    pedroguy

    Joined:
    Jan 28, 2001
    Messages:
    6,523
    Interesting.And the stack repair completed successfully ?
    Let's do this.Meat ax approach but it does sometimes work.
    In device manager,uninstall the wireless adapter and then re-boot the laptop.Let's see if it will install the adapter with drivers that are found.

    And I am now seeing that the ethernet adapter status has changed.Was it disonnected ?
     
  13. highlystrung

    highlystrung Thread Starter

    Joined:
    Apr 11, 2006
    Messages:
    15
    Stack repair ran okay.

    Can't switch on wireless - try the button but don't do ought. When I run diagnostics it says "The wireless service is not running on this computer" - I assumed that this is because the adapter is not operating...?

    shall I still try the uninstall on the artheros adapter?

    Neil
     
  14. pedroguy

    pedroguy

    Joined:
    Jan 28, 2001
    Messages:
    6,523
    Yes
    And the wireless light does not come on at all ?
     
  15. highlystrung

    highlystrung Thread Starter

    Joined:
    Apr 11, 2006
    Messages:
    15
    No wireless doesn't come on at all, can't use the restore process (says it's not working on this computer), whole PC has got very slow - I'm thinking it's had a more major issue and I need to take it back to the seller and get windows re-installed - I've got a 2 year care agreement with them. What do you think?
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/984813