can't find SETUPEXE.DLL

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

carouselbabe

Thread Starter
Joined
Sep 12, 2007
Messages
5
Hello there; been struggling to reinstall my HP printer after internet problems, (with help from HP support) but on trying to reinstall, got the message "Windows can't find SETUPEXE.DLL. The printer won't install properly, and I'm sure this is the cause. I'm beginning to think that this setup file might have gone AWOL when I uninstalled Google desktop a few days ago.
Is it safe to try and put the missing file back, and if so, how?
I don't really want to put Google desktop back, as my AV prog (Kaspersky) keeps throwing up messages about it.
Thanks!
 
Joined
Jun 10, 2007
Messages
251
just out of curiosity. Have you tried running a Spybot scan?

http://www.safer-networking.org/index2.html

Also, have you tried re-downloading the software for your printer?
Disable kaspersky when installing the software? Then re-enable it after.

After some more digging.. I did find a couple references to the file from very old posts on this forum.

You can try running System File Checker, you may need the Vista install disk.

In Windows NT-based operating systems, System File Checker can be invoked with the following command.

sfc /scannow

If it finds a problem, it will attempt to replace the problematic files from the DLL Cache (%WinDir%\System32\Dllcache\). If the file is not in the DLL Cache or the DLL Cache is corrupted, the user will be prompted to insert the Windows installation media or provide the network installation path. In Windows Vista and onwards, files are protected using Access control lists (ACLs), however the above command has not changed.
 

carouselbabe

Thread Starter
Joined
Sep 12, 2007
Messages
5
Oh, thanks very much for coming to the rescue! I've been trying to sort it out all morning, and the printer itself is now correctly installed, I'm sure - to cut a long story short it seemed to be a Vista compatability issue, and it reinstalled with compatible settings.

BUT - it still isn't working, and it's just the driver software issue now. Every time I switch the computer off and on again, it invites me to install the driver software for it, says it's installed and the printer is ready for use - but it still doesn't print. It obviously isn't installing, because it's not there on reboot.

Do you thing that Kaspersky is stopping it? I've had to temporarily switch it off before.....
 

carouselbabe

Thread Starter
Joined
Sep 12, 2007
Messages
5
Well, disabling the AV didn't make any difference! The printer is an HP 5550 series. Old but v good. But now the problem is SOLVED! The HP support eventually came up with the right solution, which turned out to be installing the printer through the Add Hardware button, as the CD didn't install it compatably after all, clearly. Nearly two solid days!!!! Don't you just love computers! Thanks again for your help; I did install Spybot and run it.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top